summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-05-09 03:12:16 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-05-09 03:12:52 +0200
commit703cb390bc2c3788f1be67600330517265b7cd47 (patch)
tree92daf7d8259a1cf08b6e6b2c58d9501cbcb1fd11 /games-arcade
parentdev-python/twisted: Remove python2_7 from PYTHON_COMPAT (diff)
downloadgentoo-703cb390bc2c3788f1be67600330517265b7cd47.tar.gz
gentoo-703cb390bc2c3788f1be67600330517265b7cd47.tar.bz2
gentoo-703cb390bc2c3788f1be67600330517265b7cd47.zip
games-arcade/supertux: Bump to version 0.6.2_rc1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/supertux/Manifest1
-rw-r--r--games-arcade/supertux/files/supertux-0.6.2_rc1-boost-1.73.patch25
-rw-r--r--games-arcade/supertux/supertux-0.6.2_rc1.ebuild61
3 files changed, 87 insertions, 0 deletions
diff --git a/games-arcade/supertux/Manifest b/games-arcade/supertux/Manifest
index 8f44c648f7ed..b2865395711f 100644
--- a/games-arcade/supertux/Manifest
+++ b/games-arcade/supertux/Manifest
@@ -1,2 +1,3 @@
DIST SuperTux-v0.6.0-Source.tar.gz 131203604 BLAKE2B 196e2ec328469b8fd373abeca6755207dbfdb8d21ba294f8150abd889f0ea8636ab3132cee94c976b8b768a6965eafe7467f09333ecf59a294405e73a5211c59 SHA512 7e313f1af1131e83ec658fee12803542d59075fa94a0a79a9182382335dc1b10a9f75092562555acf875dd03b15b336b40772fb8cdd81a82fa5802deb51b610b
DIST SuperTux-v0.6.1.1-Source.tar.gz 163363780 BLAKE2B 313c25a74b950fc292821739c9edfe5c5878fad5f74e6ba6957fb3fa3740b2dafebc443211c090c46eb30aa9906768774cae6d245ea0c88d86ef80e77283e866 SHA512 9c4b535d5c55b3a582b05dab4ffb9658fd3d500165d428eb9e69c91b03e90dcf7517cadfa99554485950085764e6589e6a0a83304abebf7911e4c5a240270c10
+DIST SuperTux-v0.6.2-rc.1-Source.tar.gz 172372034 BLAKE2B cd0825ba957bb8d3114ffefa623b32fce55467aef6ae2455fc3b7bf78ceeb58797a8ff7b2e920376e9ee1b7412ff3b5f7a9f238e2da8a9d99d9bf659d51d2ec4 SHA512 cc33e6340bbe0a7cc8f9bf11ebcecdf50e08d224de73837f5a34d67b7b4b739b1e9d148553198208cb097651d923696a28351c4ea40eaca7166b51657bb45113
diff --git a/games-arcade/supertux/files/supertux-0.6.2_rc1-boost-1.73.patch b/games-arcade/supertux/files/supertux-0.6.2_rc1-boost-1.73.patch
new file mode 100644
index 000000000000..55fa95b70fb4
--- /dev/null
+++ b/games-arcade/supertux/files/supertux-0.6.2_rc1-boost-1.73.patch
@@ -0,0 +1,25 @@
+From dec7fb943c532f855e5c0ae2eb39d2d82a46a506 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Sat, 9 May 2020 03:04:02 +0200
+Subject: [PATCH] Fix build with boost-1.73
+
+---
+ src/editor/object_settings.hpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/editor/object_settings.hpp b/src/editor/object_settings.hpp
+index bc9049a94..15b77b1e4 100644
+--- a/src/editor/object_settings.hpp
++++ b/src/editor/object_settings.hpp
+@@ -22,6 +22,8 @@
+
+ #include "editor/object_option.hpp"
+
++#include <algorithm>
++
+ class Color;
+ enum class Direction;
+ enum class WalkMode;
+--
+2.26.2
+
diff --git a/games-arcade/supertux/supertux-0.6.2_rc1.ebuild b/games-arcade/supertux/supertux-0.6.2_rc1.ebuild
new file mode 100644
index 000000000000..be67a6a7509f
--- /dev/null
+++ b/games-arcade/supertux/supertux-0.6.2_rc1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+: ${CMAKE_MAKEFILE_GENERATOR:=emake}
+inherit cmake flag-o-matic
+
+MY_PV="${PV/_rc/-rc.}"
+MY_P="SuperTux-v${MY_PV}-Source"
+
+DESCRIPTION="A game similar to Super Mario Bros."
+HOMEPAGE="https://supertux.org/"
+SRC_URI="https://github.com/SuperTux/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+ GPL-3+ ZLIB MIT CC-BY-SA-2.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-games/physfs-3.0
+ dev-libs/boost:=
+ media-libs/glew:=
+ virtual/opengl
+ media-libs/libvorbis
+ media-libs/openal
+ >=media-libs/libsdl2-2.0.1[joystick,video]
+ >=media-libs/sdl2-image-2.0.0[png,jpeg]
+ >=net-misc/curl-7.21.7"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.0-tinygettext.patch
+ "${FILESDIR}"/${PN}-0.6.0-{license,icon,obstack}.patch
+ "${FILESDIR}"/${PN}-0.6.2_rc1-boost-1.73.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ # This is not a developer release so switch the logo to the non-dev one.
+ sed -e 's@logo_dev@logo@' \
+ -i data/images/objects/logo/logo.sprite || die
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+
+ local mycmakeargs=(
+ -DWERROR=OFF
+ -DINSTALL_SUBDIR_BIN=bin
+ -DINSTALL_SUBDIR_DOC=share/doc/${PF}
+ -DINSTALL_SUBDIR_SHARE=share/${PN}2
+ -DENABLE_SQDBG="$(usex debug)"
+ -DUSE_SYSTEM_PHYSFS=ON
+ )
+ cmake_src_configure
+}