summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-15 20:13:34 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-15 21:00:12 +0200
commit75f8655ad8dbf90b30357947ab9cb74d04e02ad1 (patch)
treed5744d30e50df01c6a4859c8f8a6016d80e9a490 /games-arcade
parentapp-emulation/virt-manager: x86 stable (bug #653188) (diff)
downloadgentoo-75f8655ad8dbf90b30357947ab9cb74d04e02ad1.tar.gz
gentoo-75f8655ad8dbf90b30357947ab9cb74d04e02ad1.tar.bz2
gentoo-75f8655ad8dbf90b30357947ab9cb74d04e02ad1.zip
games-arcade/ceferino: Stop using games.eclass
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/ceferino/ceferino-0.97.8-r2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/games-arcade/ceferino/ceferino-0.97.8-r2.ebuild b/games-arcade/ceferino/ceferino-0.97.8-r2.ebuild
new file mode 100644
index 000000000000..736477bbe141
--- /dev/null
+++ b/games-arcade/ceferino/ceferino-0.97.8-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop
+
+DESCRIPTION="Super-Pang clone (destroy bouncing balloons with your grapnel)"
+HOMEPAGE="http://www.loosersjuegos.com.ar/juegos/ceferino"
+SRC_URI="mirror://debian/pool/main/c/ceferino/${PN}_${PV}+svn37.orig.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ >=media-libs/libsdl-1.2[video]
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+S="${WORKDIR}/${P}+svn37"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${P}-latin1.patch
+ sed -i \
+ -e '/^INCLUDES/s:\$(datadir)/locale:/usr/share/locale:' \
+ src/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+ newicon data/ima/icono.png ${PN}.png
+ make_desktop_entry ceferino "Don Ceferino HazaƱa"
+}
+
+pkg_postinst() {
+ if ! has_version "media-libs/sdl-mixer[mod]" ; then
+ ewarn
+ ewarn "To hear music, you will have to rebuild media-libs/sdl-mixer"
+ ewarn "with the \"mod\" USE flag turned on."
+ ewarn
+ fi
+}