summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-10 15:51:14 +0100
committerSam James <sam@gentoo.org>2022-07-10 16:45:25 +0100
commitca226b161a18e6bc3ad8af24d2ac2805e2f9aac5 (patch)
tree3634ccaab20a3d06c8d7f3c7ba3ba6315b5cf5ab /games-arcade
parentdev-util/cccc: EAPI 8 (diff)
downloadgentoo-ca226b161a18e6bc3ad8af24d2ac2805e2f9aac5.tar.gz
gentoo-ca226b161a18e6bc3ad8af24d2ac2805e2f9aac5.tar.bz2
gentoo-ca226b161a18e6bc3ad8af24d2ac2805e2f9aac5.zip
games-arcade/xbubble: EAPI 8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/xbubble/xbubble-0.5.8-r2.ebuild (renamed from games-arcade/xbubble/xbubble-0.5.8-r1.ebuild)26
1 files changed, 15 insertions, 11 deletions
diff --git a/games-arcade/xbubble/xbubble-0.5.8-r1.ebuild b/games-arcade/xbubble/xbubble-0.5.8-r2.ebuild
index 67c8f575299f..812a69873e32 100644
--- a/games-arcade/xbubble/xbubble-0.5.8-r1.ebuild
+++ b/games-arcade/xbubble/xbubble-0.5.8-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit desktop
DESCRIPTION="A Puzzle Bobble clone similar to Frozen-Bubble"
@@ -16,22 +17,24 @@ IUSE="nls"
RDEPEND="
x11-libs/libX11
x11-libs/libXt
- media-libs/libpng:0=
+ media-libs/libpng:=
nls? ( virtual/libintl )
"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
-"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
DOCS=( AUTHORS ChangeLog NEWS NetworkProtocol README TODO )
+PATCHES=(
+ "${FILESDIR}"/${P}-xpaths.patch
+ "${FILESDIR}"/${P}-locale.patch
+ "${FILESDIR}"/${P}-libpng14.patch
+ "${FILESDIR}"/${P}-png15.patch
+)
+
src_prepare() {
default
- eapply \
- "${FILESDIR}"/${P}-xpaths.patch \
- "${FILESDIR}"/${P}-locale.patch \
- "${FILESDIR}"/${P}-libpng14.patch \
- "${FILESDIR}"/${P}-png15.patch
+
sed -i \
-e '/^AM_CFLAGS/d' \
src/Makefile.in || die
@@ -45,6 +48,7 @@ src_configure() {
}
src_install() {
+
default
newicon data/themes/fancy/Bubble_black_DEAD_01.png ${PN}.png
make_desktop_entry ${PN} XBubble