summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-07 14:40:42 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-07 14:47:00 -0500
commit135e2a15cf45b98afaf3f10dbdc02335458a5b98 (patch)
treeeac4e77aa8e398dd18fdaf06286163bfe1d90303 /games-board/stockfish
parentdev-util/heaptrack: add maintainer-needed (diff)
downloadgentoo-135e2a15cf45b98afaf3f10dbdc02335458a5b98.tar.gz
gentoo-135e2a15cf45b98afaf3f10dbdc02335458a5b98.tar.bz2
gentoo-135e2a15cf45b98afaf3f10dbdc02335458a5b98.zip
games-board/stockfish: bump to EAPI 6, add maintainer-needed
Package-Manager: portage-2.2.28
Diffstat (limited to 'games-board/stockfish')
-rw-r--r--games-board/stockfish/metadata.xml1
-rw-r--r--games-board/stockfish/stockfish-6-r2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/games-board/stockfish/metadata.xml b/games-board/stockfish/metadata.xml
index cae58169f594..831231b280b4 100644
--- a/games-board/stockfish/metadata.xml
+++ b/games-board/stockfish/metadata.xml
@@ -1,6 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <!-- maintainer-needed -->
<use>
<flag name="armv7">Build for armv7; enables PIE</flag>
<flag name="general-32">Generic unoptimized 32-bits build</flag>
diff --git a/games-board/stockfish/stockfish-6-r2.ebuild b/games-board/stockfish/stockfish-6-r2.ebuild
new file mode 100644
index 000000000000..c38f33fac1c4
--- /dev/null
+++ b/games-board/stockfish/stockfish-6-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/official-stockfish/Stockfish.git"
+ KEYWORDS=""
+ S=${WORKDIR}/${P}/src
+else
+ SRC_URI="https://stockfish.s3.amazonaws.com/${P}-src.zip"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${P}-src/src
+fi
+
+DESCRIPTION="Free UCI chess engine, claimed to be the strongest in the world"
+HOMEPAGE="http://stockfishchess.org/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="armv7 cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse debug
+ general-32 general-64 +optimize"
+
+DEPEND="|| ( app-arch/unzip
+ app-arch/zip )"
+RDEPEND=""
+
+src_prepare() {
+ default
+
+ # prevent pre-stripping
+ sed -e 's:-strip $(BINDIR)/$(EXE)::' -i Makefile || die
+}
+
+src_compile() {
+ local my_arch
+ # generic unoptimized first
+ use general-32 && my_arch=general-32
+ use general-64 && my_arch=general-64
+ # x86
+ use x86 && my_arch=x86-32-old
+ use cpu_flags_x86_sse && my_arch=x86-32
+ # amd64
+ use amd64 && my_arch=x86-64
+ use cpu_flags_x86_popcnt && my_arch=x86-64-modern
+ # both bmi2 and avx2 are part of hni (haswell new instructions)
+ use cpu_flags_x86_avx2 && my_arch=x86-64-bmi2
+ # other architectures
+ use armv7 && my_arch=armv7
+ use ppc && my_arch=ppc
+ use ppc64 && my_arch=ppc64
+
+ emake build ARCH=${my_arch} \
+ debug=$(usex debug "yes" "no") \
+ optimize=$(usex optimize "yes" "no")
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+ dodoc ../AUTHORS ../Readme.md
+}