summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-01-31 17:31:18 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2016-01-31 17:32:37 -0500
commitbbfaabe4a1ed7fb66220b22424490763ab214d80 (patch)
tree4737653fa9f67ca7f01f896215194a074a2ec25c /games-board
parentdev-perl/gtk2-perl: Version bump (diff)
downloadgentoo-bbfaabe4a1ed7fb66220b22424490763ab214d80.tar.gz
gentoo-bbfaabe4a1ed7fb66220b22424490763ab214d80.tar.bz2
gentoo-bbfaabe4a1ed7fb66220b22424490763ab214d80.zip
games-board/pokerth: rev bump to move to qt5 (bug #572678)
Package-Manager: portage-2.2.26
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pokerth/files/pokerth-1.1.1-qt5.patch19
-rw-r--r--games-board/pokerth/pokerth-1.1.1-r1.ebuild66
2 files changed, 85 insertions, 0 deletions
diff --git a/games-board/pokerth/files/pokerth-1.1.1-qt5.patch b/games-board/pokerth/files/pokerth-1.1.1-qt5.patch
new file mode 100644
index 000000000000..1d3dd63922fb
--- /dev/null
+++ b/games-board/pokerth/files/pokerth-1.1.1-qt5.patch
@@ -0,0 +1,19 @@
+From 731f5f05f54065a67fa7c9f9bc8fe992390cb979 Mon Sep 17 00:00:00 2001
+From: Felix Hammer <f.hammer@web.de>
+Date: Fri, 7 Aug 2015 00:57:51 +0200
+Subject: [PATCH] Qt 5.5.0 patch for qtsingleapplication
+
+---
+ src/third_party/qtsingleapplication/qtlocalpeer.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/src/third_party/qtsingleapplication/qtlocalpeer.cpp
++++ b/src/third_party/qtsingleapplication/qtlocalpeer.cpp
+@@ -31,6 +31,7 @@
+
+ #include <QCoreApplication>
+ #include <QTime>
++#include <QDataStream>
+
+ #if defined(Q_OS_WIN)
+ #include <QLibrary>
diff --git a/games-board/pokerth/pokerth-1.1.1-r1.ebuild b/games-board/pokerth/pokerth-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..977229daf5b5
--- /dev/null
+++ b/games-board/pokerth/pokerth-1.1.1-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic eutils qmake-utils games
+
+MY_P="PokerTH-${PV}-src"
+DESCRIPTION="Texas Hold'em poker game"
+HOMEPAGE="http://www.pokerth.net/"
+SRC_URI="mirror://sourceforge/pokerth/${MY_P}.tar.bz2"
+
+LICENSE="AGPL-3 GPL-1 GPL-2 GPL-3 BitstreamVera public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated"
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/boost:=[threads(+)]
+ dev-libs/protobuf
+ dev-libs/libgcrypt:0
+ dev-libs/tinyxml[stl]
+ >=net-libs/libircclient-1.6-r2
+ >=net-misc/curl-7.16
+ dev-qt/qtcore:5
+ virtual/gsasl
+ !dedicated? (
+ media-libs/libsdl:0
+ media-libs/sdl-mixer[mod,vorbis]
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtnetwork:5
+ )"
+DEPEND="${RDEPEND}
+ !dedicated? ( dev-qt/qtsql:5 )
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if use dedicated ; then
+ sed -i -e 's/pokerth_game.pro//' pokerth.pro || die
+ fi
+
+ sed -i -e '/no_dead_strip_inits_and_terms/d' *pro || die
+
+ epatch "${FILESDIR}"/${P}-qt5.patch
+}
+
+src_configure() {
+ eqmake5 pokerth.pro
+}
+
+src_install() {
+ dogamesbin bin/pokerth_server
+ if ! use dedicated ; then
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data
+ domenu ${PN}.desktop
+ doicon ${PN}.png
+ fi
+ doman docs/pokerth.1
+ dodoc ChangeLog TODO docs/{gui_styling,server_setup}_howto.txt
+ prepgamesdirs
+}