summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-29 09:05:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-29 09:09:24 +0200
commit650236e9939157e369d959bba9704bd5d0613b2b (patch)
tree9dec999c2c7b16219271baa191d52ac584f1ec8b /games-emulation/atari800
parentdev-python/starlette: Bump to 0.20.1 (diff)
downloadgentoo-650236e9939157e369d959bba9704bd5d0613b2b.tar.gz
gentoo-650236e9939157e369d959bba9704bd5d0613b2b.tar.bz2
gentoo-650236e9939157e369d959bba9704bd5d0613b2b.zip
games-emulation/atari800: Bump to 5.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'games-emulation/atari800')
-rw-r--r--games-emulation/atari800/Manifest1
-rw-r--r--games-emulation/atari800/atari800-5.0.0.ebuild86
-rw-r--r--games-emulation/atari800/metadata.xml5
3 files changed, 91 insertions, 1 deletions
diff --git a/games-emulation/atari800/Manifest b/games-emulation/atari800/Manifest
index 8955c0ab3425..a5f28f5de9c0 100644
--- a/games-emulation/atari800/Manifest
+++ b/games-emulation/atari800/Manifest
@@ -1,2 +1,3 @@
DIST atari800-4.2.0-src.tgz 7047710 BLAKE2B eac4b2da03d2ff5ec9e18dda41e0345975ed16c1cee23d15d2633211b7d4835b7a26c79fbf1672bb9ce3b82d52c7273e717371a0065ba29807f76d823eeb9855 SHA512 1236a8e05bf878e4514ae8e9f1556e0961a7f11ff0333eef415af455d217f712d5c6ededdd343dff6ba1aab777e19997bf9ecb859408187d69fc141301ecba31
+DIST atari800-5.0.0-src.tgz 1847596 BLAKE2B 315afa4fc8d88c2267c3da04f50a541a871f2d9d0867030b30e8f5d22b421f73f89de85ea1c7d6bc41202304de43d482f5d0fd9a081b4e493b3bba1363ce1e71 SHA512 2469561cdfe185ad26fd0fff8d589c528ca267e0195dab58a0fe739674f7445b53c21070f6bcb838c1d776b9803b1e2874ecf58a36b2d6df04bd9eb38855bfac
DIST xf25.zip 188942 BLAKE2B c10b9108eebc571ac334ea6fca76d227e3d2fcde1595e8823a3d178dc31d9efa9b209572ee03875461289093615470192cf5c9a06cf0b4363d097a9eac201db4 SHA512 306612fc2af41ed10d76103af83e141cfd8bd3ba2ea3cbd1d0b81d4d5b0108c06948a5c626648c8a2424536757a42a3f8b9af1fb63fa3c31096447ffed0f9923
diff --git a/games-emulation/atari800/atari800-5.0.0.ebuild b/games-emulation/atari800/atari800-5.0.0.ebuild
new file mode 100644
index 000000000000..8ad5a7e21a69
--- /dev/null
+++ b/games-emulation/atari800/atari800-5.0.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop
+
+DESCRIPTION="Atari 800 emulator"
+HOMEPAGE="https://atari800.github.io/"
+SRC_URI="
+ https://github.com/atari800/atari800/releases/download/ATARI800_${PV//./_}/${P}-src.tgz
+ https://sourceforge.net/projects/${PN}/files/ROM/Original%20XL%20ROM/xf25.zip"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="encode-mp3 opengl readline +sdl +sound"
+REQUIRED_USE="
+ encode-mp3? ( sound )
+ opengl? ( sdl )
+"
+
+DEPEND="
+ encode-mp3? (
+ media-sound/lame
+ )
+ sdl? (
+ >=media-libs/libsdl-1.2.0[joystick,opengl?,sound?,video]
+ )
+ !sdl? (
+ sys-libs/ncurses:=
+ )
+ readline? (
+ sys-libs/readline:=
+ sys-libs/ncurses:=
+ )
+ media-libs/libpng:=
+ sys-libs/zlib
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+src_prepare() {
+ local PATCHES=(
+ # Bug 544608
+ "${FILESDIR}"/atari800-3.1.0-tgetent-detection.patch
+ )
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local video=ncurses
+ local sound=no
+
+ if use sdl; then
+ video=sdl
+ use sound && sound=sdl
+ elif use sound; then
+ sound=oss
+ fi
+
+ local myconf=(
+ $(use_with opengl)
+ $(use_with readline)
+ $(use_with encode-mp3 mp3)
+ --with-video=${video}
+ --with-sound=${sound}
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ insinto "/usr/share/${PN}"
+ doins "${WORKDIR}/"*.ROM
+ insinto /etc
+ newins "${FILESDIR}"/atari800-4.2.0.cfg atari800.cfg
+ newicon data/atari2.svg ${PN}.svg
+ make_desktop_entry ${PN} "Atari 800 emulator"
+}
diff --git a/games-emulation/atari800/metadata.xml b/games-emulation/atari800/metadata.xml
index 93a5cf72aa74..70220fb60e13 100644
--- a/games-emulation/atari800/metadata.xml
+++ b/games-emulation/atari800/metadata.xml
@@ -26,9 +26,12 @@ ways :
* SDL (many different platforms and systems)
* WinCE
* MacOS X
-</longdescription>
+ </longdescription>
<upstream>
<remote-id type="sourceforge">atari800</remote-id>
<remote-id type="github">atari800/atari800</remote-id>
</upstream>
+ <use>
+ <flag name="encode-mp3">Support recording sound in MP3 format</flag>
+ </use>
</pkgmetadata>