summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-10-30 09:26:19 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-10-30 09:27:55 +0100
commit784ae9a3c81ec25fc5fb5f291c325bd09ea02319 (patch)
treeb554968f8459acb0cc62db9b6720300ad30d74d3 /games-emulation/mgba/mgba-9999.ebuild
parentgames-emulation/mgba: Bump to version 0.8.4 (diff)
downloadgentoo-784ae9a3c81ec25fc5fb5f291c325bd09ea02319.tar.gz
gentoo-784ae9a3c81ec25fc5fb5f291c325bd09ea02319.tar.bz2
gentoo-784ae9a3c81ec25fc5fb5f291c325bd09ea02319.zip
games-emulation/mgba: Synced live ebuild
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-emulation/mgba/mgba-9999.ebuild')
-rw-r--r--games-emulation/mgba/mgba-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/games-emulation/mgba/mgba-9999.ebuild b/games-emulation/mgba/mgba-9999.ebuild
index d1d5df90464f..e34b02d22965 100644
--- a/games-emulation/mgba/mgba-9999.ebuild
+++ b/games-emulation/mgba/mgba-9999.ebuild
@@ -49,6 +49,7 @@ src_prepare() {
cmake_src_prepare
# Get rid of any bundled stuff we don't want
+ local pkg
for pkg in libpng lzma sqlite3 zlib ; do
rm -r src/third-party/${pkg} || die
done
@@ -92,7 +93,7 @@ src_compile() {
src_install() {
if use qt5 ; then
- dobin ../${P}_build/qt/${PN}-qt
+ dobin ${BUILD_DIR}/qt/${PN}-qt
doman doc/${PN}-qt.6
domenu res/${PN}-qt.desktop
for size in 16 24 32 48 64 96 128 256 ; do
@@ -101,10 +102,10 @@ src_install() {
fi
if use sdl ; then
doman doc/${PN}.6
- newbin ../${P}_build/sdl/${PN} ${PN}-sdl
+ newbin ${BUILD_DIR}/sdl/${PN} ${PN}-sdl
fi
- dolib.so ../${P}_build/lib${PN}.so*
+ dolib.so ${BUILD_DIR}/lib${PN}.so*
}
pkg_preinst() {