summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-03 15:24:09 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-03 15:26:41 +0100
commitced341362df8b763f8330ed73b4f1561735dee51 (patch)
treeb06ccefcb49eb50c10a3da66d42c114f0c07ac15 /games-emulation/snes9x
parentdev-libs/libutf8proc: remove unused patch(es) (diff)
downloadgentoo-ced341362df8b763f8330ed73b4f1561735dee51.tar.gz
gentoo-ced341362df8b763f8330ed73b4f1561735dee51.tar.bz2
gentoo-ced341362df8b763f8330ed73b4f1561735dee51.zip
games-emulation/snes9x: Bump to version 1.59
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-emulation/snes9x')
-rw-r--r--games-emulation/snes9x/Manifest1
-rw-r--r--games-emulation/snes9x/files/snes9x-1.59-build-system.patch40
-rw-r--r--games-emulation/snes9x/snes9x-1.59.ebuild128
3 files changed, 169 insertions, 0 deletions
diff --git a/games-emulation/snes9x/Manifest b/games-emulation/snes9x/Manifest
index 0e2e1b50958f..c4da18a9d028 100644
--- a/games-emulation/snes9x/Manifest
+++ b/games-emulation/snes9x/Manifest
@@ -1,2 +1,3 @@
DIST snes9x-1.57.tar.gz 2959157 BLAKE2B 6307976247eb3a3bcb506028d75d9054ea853db5c629870a89832fd93ee2fe256799b9191922c67fcd8ef1ed2344d16326212001661c5038a88f290346b9f35c SHA512 d17ec45eeae8f57c618a51243ac54bc3a2a3f09632e4e50c51781cf8557362dbfa7856d9d4ecdebeea344041c2686e2256f6bcd2dcc71660fcf336cf887dcb1c
DIST snes9x-1.58.tar.gz 2830667 BLAKE2B 66446e56a172b318f7cefecc59d927270377f725df0ca89888e1c50eb3f5475729ffc9da86ead5e50f106ab0781ad644ae3b3ed5719724db9b78b687135ead04 SHA512 51f8e92258db58e55f7b0b6c4537a916358891bb5ee35bd984d1970d2fedbdb2f8b3a4f560e0302d3011e521a1072c8a0d69723e8b151f61d33802c02f392d7d
+DIST snes9x-1.59.tar.gz 2819790 BLAKE2B 63328f034bbd8b9905346836e52344c86dccf04e57d8b1d280485d1ff24e3b1d452c2529526b477066d6ace8a0f2aba07e62d98e85bd0eae4d21f0c0186e0587 SHA512 e9bec3e9908705f3ff380c6e2131b8ff7c9a7fc5571a00f05c0f7810a2edd2fe36dd4def242bdb924e9f6d15a303794a626358cd49dedab9a2794e80a2cc920a
diff --git a/games-emulation/snes9x/files/snes9x-1.59-build-system.patch b/games-emulation/snes9x/files/snes9x-1.59-build-system.patch
new file mode 100644
index 000000000000..2d8f9f05e59f
--- /dev/null
+++ b/games-emulation/snes9x/files/snes9x-1.59-build-system.patch
@@ -0,0 +1,40 @@
+--- snes9x-1.59/unix/configure.ac
++++ snes9x-1.59/unix/configure.ac
+@@ -56,37 +56,6 @@
+ # *** Execution begins here ***
+ # *****************************
+
+-# Test what compiler flags we should use.
+-
+-AC_ARG_ENABLE([debug],
+- [AS_HELP_STRING([--enable-debug],
+- [leave debug information in the final binary (default: no)])],
+- [], [enable_debug="no"])
+-
+-if test "x$enable_debug" = "xyes"; then
+- AC_S9X_COMPILER_FLAG([-g], [g])
+- AC_S9X_COMPILER_FLAG([-O0], [o0])
+-else
+- AC_S9X_COMPILER_FLAG([-O3], [o3], [
+- AC_S9X_COMPILER_FLAG([-O2], [o2], [
+- AC_S9X_COMPILER_FLAG([-O1], [o1])])])
+- AC_S9X_COMPILER_FLAG([-fomit-frame-pointer], [omit_frame_pointer])
+-fi
+-
+-AC_ARG_ENABLE([mtune],
+- [AS_HELP_STRING([--enable-mtune],
+- [use the specified value for the -mtune/-mcpu flag (default: no)])],
+- [], [enable_mtune="no"])
+-
+-if test "x$enable_mtune" != "xno"; then
+- AC_S9X_COMPILER_FLAG([-mtune="$enable_mtune"], [mtune],
+- [
+- AC_MSG_WARN([-mtune failed, trying -mcpu...])
+- AC_S9X_COMPILER_FLAG([-mcpu="$enable_mtune"], [mcpu],
+- [AC_MSG_ERROR([Please specify a working value for --enable-mtune.])])
+- ])
+-fi
+-
+ AC_S9X_COMPILER_FLAG([-fno-exceptions], [no_exceptions])
+ AC_S9X_COMPILER_FLAG([-fno-rtti], [no_rtti])
+ AC_S9X_COMPILER_FLAG([-pedantic], [pedantic])
diff --git a/games-emulation/snes9x/snes9x-1.59.ebuild b/games-emulation/snes9x/snes9x-1.59.ebuild
new file mode 100644
index 000000000000..830686b140fa
--- /dev/null
+++ b/games-emulation/snes9x/snes9x-1.59.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic meson xdg
+
+DESCRIPTION="Super Nintendo Entertainment System (SNES) emulator"
+HOMEPAGE="https://github.com/snes9xgit/snes9x"
+SRC_URI="https://github.com/snes9xgit/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Snes9x GPL-2 GPL-2+ LGPL-2.1 LGPL-2.1+ ISC MIT ZLIB Info-ZIP"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd"
+IUSE="alsa debug gtk multilib netplay opengl oss png pulseaudio portaudio wayland xinerama +xv"
+RESTRICT="bindist"
+
+RDEPEND="
+ sys-libs/zlib:=[minizip]
+ x11-libs/libX11
+ x11-libs/libXext
+ png? ( media-libs/libpng:0= )
+ gtk? (
+ dev-libs/glib:2
+ media-libs/libsdl2[joystick]
+ >=x11-libs/gtk+-3.22:3[wayland?]
+ x11-libs/libXrandr
+ x11-misc/xdg-utils
+ alsa? ( media-libs/alsa-lib )
+ opengl? (
+ media-libs/libepoxy
+ virtual/opengl
+ )
+ portaudio? ( >=media-libs/portaudio-19_pre )
+ pulseaudio? ( media-sound/pulseaudio )
+ xv? ( x11-libs/libXv )
+ wayland? ( dev-libs/wayland )
+ )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${P}/unix"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.53-cross-compile.patch
+ "${FILESDIR}"/${PN}-1.59-build-system.patch
+)
+
+src_prepare() {
+ cd "${WORKDIR}/${P}" || die
+ rm -r unzip || die
+ default
+ cd unix || die
+ eautoreconf
+ if use gtk ; then
+ export EMESON_SOURCE="${WORKDIR}/${P}/gtk"
+ fi
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+
+ # build breaks when zlib/zip support is disabled
+ local myeconfargs=(
+ --enable-gamepad
+ --enable-gzip
+ --enable-zip
+ --with-system-zip
+ $(use_enable debug debugger)
+ $(use_enable netplay)
+ $(use_enable png screenshot)
+ $(use_enable xinerama)
+ )
+ econf "${myeconfargs[@]}"
+
+ if use gtk; then
+ local emesonargs=(
+ -Dalsa="$(usex alsa true false)"
+ -Ddebugger="$(usex debug true false)"
+ -Dgtk2=false
+ -Dgtk3=true
+ -Dopengl="$(usex opengl true false)"
+ -Doss="$(usex oss true false)"
+ -Dportaudio="$(usex portaudio true false)"
+ -Dpulseaudio="$(usex pulseaudio true false)"
+ -Dscreenshot="$(usex png true false)"
+ -Dsystem-zip=true
+ -Dxv="$(usex xv true false)"
+ -Dzlib=true
+ -Dwayland="$(usex wayland true false)"
+ )
+ meson_src_configure
+ fi
+}
+
+src_compile() {
+ emake
+ use gtk && meson_src_compile
+}
+
+src_install() {
+ dobin ${PN}
+
+ dodoc ../docs/{changes,control-inputs,controls,snapshots}.txt
+ dodoc snes9x.conf.default
+
+ if use gtk ; then
+ meson_src_install
+ dodoc ../gtk/AUTHORS
+ fi
+
+ docinto html
+ dodoc {.,..}/docs/*.html
+}
+
+pkg_preinst() {
+ use gtk && xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ use gtk && xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ use gtk && xdg_pkg_postrm
+}