summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-08-19 03:38:49 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-08-19 03:47:06 -0400
commit000a999d456d104ab86080f300ced8ce927db87d (patch)
tree774bafe49b3e22ce08929fa6f53f3ffc635f1433 /games-emulation
parentgames-emulation/atari800: Fix some basisms in configure (diff)
downloadgentoo-000a999d456d104ab86080f300ced8ce927db87d.tar.gz
gentoo-000a999d456d104ab86080f300ced8ce927db87d.tar.bz2
gentoo-000a999d456d104ab86080f300ced8ce927db87d.zip
games-emulation/gnuboy: EAPI 7->8, tidy, actually add [joystick]
Also [sound,video] as it uses both, and libX11 Fixes: 91aff97f2dac6a7897dff1da831d3d9243955307 Closes: https://bugs.gentoo.org/809020 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/gnuboy/gnuboy-1.0.3-r4.ebuild (renamed from games-emulation/gnuboy/gnuboy-1.0.3-r3.ebuild)42
1 files changed, 20 insertions, 22 deletions
diff --git a/games-emulation/gnuboy/gnuboy-1.0.3-r3.ebuild b/games-emulation/gnuboy/gnuboy-1.0.3-r4.ebuild
index 9fd915b37c0a..6fcd97ea2826 100644
--- a/games-emulation/gnuboy/gnuboy-1.0.3-r3.ebuild
+++ b/games-emulation/gnuboy/gnuboy-1.0.3-r4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
@@ -12,16 +12,18 @@ SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+sdl X"
+IUSE="X +sdl"
REQUIRED_USE="!X? ( sdl )"
RDEPEND="
- sdl? ( media-libs/libsdl )
- X? ( x11-libs/libXext )
-"
-DEPEND="${RDEPEND}
- X? ( x11-base/xorg-proto )
-"
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ )
+ sdl? ( media-libs/libsdl[joystick,sound,video] )"
+DEPEND="
+ ${RDEPEND}
+ X? ( x11-base/xorg-proto )"
PATCHES=(
"${FILESDIR}"/${P}-exec-stack.patch
@@ -33,28 +35,24 @@ PATCHES=(
src_prepare() {
default
- mv configure.in configure.ac || die
eautoreconf
}
src_configure() {
- local myconf
-
- econf \
- $(use_with X x) \
- $(use_with sdl) \
- $(use_enable x86 asm) \
- ${myconf} \
- --disable-arch \
+ local econfargs=(
+ $(use_with X x)
+ $(use_with sdl)
+ $(use_enable x86 asm)
+ --disable-arch
--disable-optimize
+ )
+
+ econf "${econfargs[@]}"
}
src_install() {
- for f in sdlgnuboy xgnuboy; do
- if [[ -f ${f} ]] ; then
- dobin ${f}
- fi
- done
+ use X && dobin xgnuboy
+ use sdl && dobin sdlgnuboy
dodoc README docs/{CHANGES,CONFIG,CREDITS,FAQ,HACKING,WHATSNEW}
}