summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-03-09 09:46:17 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-03-09 09:46:17 +0100
commit117f6634d01f2c89e614561de47351c9bdfef37a (patch)
tree4491e417de083e5d5f7607cb1f5aa91f03891485 /games-emulation
parentgames-arcade/crack-attack: EAPI-7 bump. Avoid bashisms. (diff)
downloadgentoo-117f6634d01f2c89e614561de47351c9bdfef37a.tar.gz
gentoo-117f6634d01f2c89e614561de47351c9bdfef37a.tar.bz2
gentoo-117f6634d01f2c89e614561de47351c9bdfef37a.zip
games-emulation/vbam: Fixed build against libsdl2-2.0.14
Closes: https://bugs.gentoo.org/762208 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/vbam/files/vbam-2.1.4-libsdl2-2.0.14.patch27
-rw-r--r--games-emulation/vbam/vbam-2.1.4.ebuild3
2 files changed, 29 insertions, 1 deletions
diff --git a/games-emulation/vbam/files/vbam-2.1.4-libsdl2-2.0.14.patch b/games-emulation/vbam/files/vbam-2.1.4-libsdl2-2.0.14.patch
new file mode 100644
index 000000000000..a528a22e506e
--- /dev/null
+++ b/games-emulation/vbam/files/vbam-2.1.4-libsdl2-2.0.14.patch
@@ -0,0 +1,27 @@
+From 619a5cce683ec4b1d03f08f316ba276d8f8cd824 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?R=C3=A9mi=20Verschelde?= <rverschelde@gmail.com>
+Date: Thu, 31 Dec 2020 00:22:21 +0100
+Subject: [PATCH] SDL: Fix build with SDL 2.0.14 after KMOD_GUI change to enum
+
+Since SDL 2.0.14, KMOD_GUI is no longer a macro but an enum value:
+https://hg.libsdl.org/SDL/rev/15a0bc9612e9
+
+So this code broke as the enum value doesn't satisfy `defined()`.
+---
+ src/sdl/SDL.cpp | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/sdl/SDL.cpp b/src/sdl/SDL.cpp
+index ee8ae50a3..082b47c0c 100644
+--- a/src/sdl/SDL.cpp
++++ b/src/sdl/SDL.cpp
+@@ -878,7 +878,8 @@ void sdlInitVideo()
+
+ sdlResizeVideo();
+ }
+-#if defined(KMOD_GUI)
++
++#ifndef KMOD_META
+ #define KMOD_META KMOD_GUI
+ #endif
+
diff --git a/games-emulation/vbam/vbam-2.1.4.ebuild b/games-emulation/vbam/vbam-2.1.4.ebuild
index b9fd01b61bd3..21f3c2cf4a23 100644
--- a/games-emulation/vbam/vbam-2.1.4.ebuild
+++ b/games-emulation/vbam/vbam-2.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -56,6 +56,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${P}-cmake_fix.patch
+ "${FILESDIR}"/${P}-libsdl2-2.0.14.patch #762208
)
src_configure() {