summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-29 13:22:31 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-29 13:26:26 +0200
commit35f55f98cdb871dfd7e257174fe2a3ffdacc3d81 (patch)
treef47059b3142d6a8debc1bc2e8fcd31b943dcbe55 /games-emulation
parentgames-emulation/mamory: Make repoman happy (diff)
downloadgentoo-35f55f98cdb871dfd7e257174fe2a3ffdacc3d81.tar.gz
gentoo-35f55f98cdb871dfd7e257174fe2a3ffdacc3d81.tar.bz2
gentoo-35f55f98cdb871dfd7e257174fe2a3ffdacc3d81.zip
games-emulation/mednaffe: Version bump
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mednaffe/Manifest1
-rw-r--r--games-emulation/mednaffe/mednaffe-0.8.7.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/games-emulation/mednaffe/Manifest b/games-emulation/mednaffe/Manifest
index e46469bfe6f9..2637c79cc939 100644
--- a/games-emulation/mednaffe/Manifest
+++ b/games-emulation/mednaffe/Manifest
@@ -1 +1,2 @@
+DIST mednaffe-0.8.7.tar.gz 304300 BLAKE2B 80a57f2afbea0e33ec547f16088b678fd9a319a124bbebe71fe7848497e1276ae77c0fb47718324d8549dbb69709685f46c970dedf982f48ac095f1923b42dbd SHA512 3495ecd3b87f19ab65d8760ea8adfa830c4dc9fe959f2e2f349216b36f58d9623c9cfd0c7e40fe5e8b7b90846fe85d9808c2a5885f36d5d8b16659b25cf8a3a1
DIST mednaffe-0.8.zip 311381 BLAKE2B cffa364f58c83dfed85141ed6e740b0e31b76524e8a336b332d79884f745e8d918cfd78658ded4c377b384ccb7dbb921aa883ff3bb0a0d413a2bb00365f0f4a0 SHA512 54747318da956616af2fedba5d9760629d0064140b4aa2bd652208c4fda8cb24dec60d869d6999aaa371d837adcaf0c6761f843277c999c33d98cfdd07bf3776
diff --git a/games-emulation/mednaffe/mednaffe-0.8.7.ebuild b/games-emulation/mednaffe/mednaffe-0.8.7.ebuild
new file mode 100644
index 000000000000..904241ddac84
--- /dev/null
+++ b/games-emulation/mednaffe/mednaffe-0.8.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic gnome2-utils
+
+DESCRIPTION="A front-end (GUI) for mednafen emulator"
+HOMEPAGE="https://github.com/AmatCoder/mednaffe"
+SRC_URI="https://github.com/AmatCoder/mednaffe/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ games-emulation/mednafen[debugger]
+ >=x11-libs/gtk+-3.4:3
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ append-cflags -Wl,-export-dynamic
+ sed -i -e 's:$(datadir):/usr/share:' share/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-gtk3
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}