summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-07-05 02:23:29 +0200
committerDavid Seifert <soap@gentoo.org>2020-07-05 02:23:29 +0200
commit50d012f7120607d69c10e0938e16fa392bf699d7 (patch)
tree48b4fc56b6e9bd93cecbc12399570b86dff57124 /games-emulation
parentgames-emulation/generator: Fix build system (diff)
downloadgentoo-50d012f7120607d69c10e0938e16fa392bf699d7.tar.gz
gentoo-50d012f7120607d69c10e0938e16fa392bf699d7.tar.bz2
gentoo-50d012f7120607d69c10e0938e16fa392bf699d7.zip
games-emulation/dgen-sdl: Call AM_PROG_AR
Closes: https://bugs.gentoo.org/724410 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild29
-rw-r--r--games-emulation/dgen-sdl/files/dgen-sdl-1.33-AM_PROG_AR.patch10
2 files changed, 29 insertions, 10 deletions
diff --git a/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild b/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild
index 5d9acdc094b9..c80d660bf3e8 100644
--- a/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild
+++ b/games-emulation/dgen-sdl/dgen-sdl-1.33-r1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit autotools
DESCRIPTION="A Linux/SDL-Port of the famous DGen MegaDrive/Genesis-Emulator"
HOMEPAGE="http://dgen.sourceforge.net/"
@@ -15,13 +17,19 @@ IUSE="joystick opengl"
RDEPEND="
media-libs/libsdl[joystick?,opengl?]
app-arch/libarchive
- opengl? ( virtual/opengl )
-"
-DEPEND="${RDEPEND}
- x86? ( dev-lang/nasm )
-"
-
-PATCHES=( "${FILESDIR}"/${P}-joystick.patch )
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}"
+BDEPEND="x86? ( dev-lang/nasm )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-joystick.patch
+ "${FILESDIR}"/${P}-AM_PROG_AR.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
econf \
@@ -36,5 +44,6 @@ src_compile() {
}
src_install() {
- DOCS="AUTHORS ChangeLog README sample.dgenrc" default
+ default
+ dodoc sample.dgenrc
}
diff --git a/games-emulation/dgen-sdl/files/dgen-sdl-1.33-AM_PROG_AR.patch b/games-emulation/dgen-sdl/files/dgen-sdl-1.33-AM_PROG_AR.patch
new file mode 100644
index 000000000000..e04efcc01f38
--- /dev/null
+++ b/games-emulation/dgen-sdl/files/dgen-sdl-1.33-AM_PROG_AR.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -25,6 +25,7 @@
+ AC_PROG_CXXCPP
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
++AM_PROG_AR
+ AC_PROG_RANLIB
+
+ dnl Set the value of make, if make doesn't already.