summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobinDX <robin9800xt@gmail.com>2016-01-31 01:34:14 +0800
committerPatrice Clement <monsieurp@gentoo.org>2016-01-31 00:13:59 +0000
commit564407a6307553f4c70301307b3fc9a60667d65b (patch)
tree07d6a1fe30038c0bcbd12adc502dd6daeca9a6a5 /games-emulation
parentdev-java/icedtea: Remove unused fontconfig.Gentoo.properties.src (diff)
downloadgentoo-564407a6307553f4c70301307b3fc9a60667d65b.tar.gz
gentoo-564407a6307553f4c70301307b3fc9a60667d65b.tar.bz2
gentoo-564407a6307553f4c70301307b3fc9a60667d65b.zip
games-emulation/ppsspp: bug fix #572606
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/ppsspp/ppsspp-1.1.0-r1.ebuild (renamed from games-emulation/ppsspp/ppsspp-1.1.0.ebuild)9
-rw-r--r--games-emulation/ppsspp/ppsspp-1.1.1-r1.ebuild (renamed from games-emulation/ppsspp/ppsspp-1.1.1.ebuild)9
-rw-r--r--games-emulation/ppsspp/ppsspp-9999-r1.ebuild (renamed from games-emulation/ppsspp/ppsspp-9999.ebuild)9
3 files changed, 24 insertions, 3 deletions
diff --git a/games-emulation/ppsspp/ppsspp-1.1.0.ebuild b/games-emulation/ppsspp/ppsspp-1.1.0-r1.ebuild
index 0f5df8af1706..d7e7c64e7e9d 100644
--- a/games-emulation/ppsspp/ppsspp-1.1.0.ebuild
+++ b/games-emulation/ppsspp/ppsspp-1.1.0-r1.ebuild
@@ -103,7 +103,7 @@ src_compile() {
src_install() {
if use qt4 ; then
- exeinto /usr/games/bin
+ into /usr/games/bin
newexe "${WORKDIR}"/"${P}"/Qt/ppsspp ppsspp
elif use qt5 ; then
exeinto /usr/games/bin
@@ -121,3 +121,10 @@ src_install() {
newins "${WORKDIR}"/"${P}"/source_assets/image/icon_regular_72.png ppsspp-icon.png
domenu "${FILESDIR}"/ppsspp.desktop
}
+
+pkg_postinst() {
+ elog "Remember, in order to play games, you have to "
+ elog "be in the 'games' group. "
+ elog "Just run 'gpasswd -a <USER> games', then have <USER> re-login. "
+}
+
diff --git a/games-emulation/ppsspp/ppsspp-1.1.1.ebuild b/games-emulation/ppsspp/ppsspp-1.1.1-r1.ebuild
index 0f5df8af1706..d7e7c64e7e9d 100644
--- a/games-emulation/ppsspp/ppsspp-1.1.1.ebuild
+++ b/games-emulation/ppsspp/ppsspp-1.1.1-r1.ebuild
@@ -103,7 +103,7 @@ src_compile() {
src_install() {
if use qt4 ; then
- exeinto /usr/games/bin
+ into /usr/games/bin
newexe "${WORKDIR}"/"${P}"/Qt/ppsspp ppsspp
elif use qt5 ; then
exeinto /usr/games/bin
@@ -121,3 +121,10 @@ src_install() {
newins "${WORKDIR}"/"${P}"/source_assets/image/icon_regular_72.png ppsspp-icon.png
domenu "${FILESDIR}"/ppsspp.desktop
}
+
+pkg_postinst() {
+ elog "Remember, in order to play games, you have to "
+ elog "be in the 'games' group. "
+ elog "Just run 'gpasswd -a <USER> games', then have <USER> re-login. "
+}
+
diff --git a/games-emulation/ppsspp/ppsspp-9999.ebuild b/games-emulation/ppsspp/ppsspp-9999-r1.ebuild
index e60451b5191d..9dd2ba9157a8 100644
--- a/games-emulation/ppsspp/ppsspp-9999.ebuild
+++ b/games-emulation/ppsspp/ppsspp-9999-r1.ebuild
@@ -102,7 +102,7 @@ src_compile() {
src_install() {
if use qt4 ; then
- exeinto /usr/games/bin
+ into /usr/games/bin
newexe "${WORKDIR}"/"${P}"/Qt/ppsspp ppsspp
elif use qt5 ; then
exeinto /usr/games/bin
@@ -120,3 +120,10 @@ src_install() {
newins "${WORKDIR}"/"${P}"/source_assets/image/icon_regular_72.png ppsspp-icon.png
domenu "${FILESDIR}"/ppsspp.desktop
}
+
+pkg_postinst() {
+ elog "Remember, in order to play games, you have to "
+ elog "be in the 'games' group. "
+ elog "Just run 'gpasswd -a <USER> games', then have <USER> re-login. "
+}
+