summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-01 19:28:33 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-01 19:47:01 +0200
commitdff1e77b48f2d08ef980aab0d41821d17256dc3e (patch)
treeebee675c124db5a88e97c38a116006d609be1bf7 /games-emulation
parentsys-apps/openrazer: add 3.6.0 (diff)
downloadgentoo-dff1e77b48f2d08ef980aab0d41821d17256dc3e.tar.gz
gentoo-dff1e77b48f2d08ef980aab0d41821d17256dc3e.tar.bz2
gentoo-dff1e77b48f2d08ef980aab0d41821d17256dc3e.zip
games-emulation/ppsspp: bump to 1.15
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/ppsspp/Manifest1
-rw-r--r--games-emulation/ppsspp/ppsspp-1.15.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/games-emulation/ppsspp/Manifest b/games-emulation/ppsspp/Manifest
index 71f0b40d7f0c..1e2d4614cad9 100644
--- a/games-emulation/ppsspp/Manifest
+++ b/games-emulation/ppsspp/Manifest
@@ -1,2 +1,3 @@
DIST ppsspp-1.14.2.tar.xz 46414560 BLAKE2B 3b1cc4a1f7824be4fe0e9abaf52df333965a9b2000bb412b71ea8308a75d4f250ff80c8097856720eb6339926e0b73bb725844f6cabeededc0c2475342a003a9 SHA512 767345235faa54c6a0c19c41fead43f67c39d7f84cd3d573523a745cd082166910090789a985873be047ecaf17513ef318362041f5dcc2b068b1ff061d787f79
DIST ppsspp-1.14.4.tar.xz 46405556 BLAKE2B 6ba958e8bcefffeeb0d05f3c14cf7381737a02deed27c45d564ba4e556af5654e51ffad5c8a8f880ce85b8916db4ed51b8be13c1ca01f7b6d7b28fa266425605 SHA512 144f5af637f747c745a34d28c95d498cfc736777240ad4eb0a08721af2fcb36106cf93a73d49df0fb572ee7ec78b4bc0965c9f4b3845e9457a4d7c967b8389ec
+DIST ppsspp-1.15.tar.xz 52176784 BLAKE2B f0733edd114e09c3dfc4910fb48b7c5687af06faf39ed9184429d5f9ad0af3149a9270426b92eccbe97f61e436e7399c49e4feb0db05ce9df4d4177d091d7a08 SHA512 88e97f964e826cf791725ed62178dbfa456094af06a1c896df640b24a4e2ae8ed79e0ae63cb29cc6a92e83ecd63ab60013ddf32333fb1e8b5024a6e3fce6b71f
diff --git a/games-emulation/ppsspp/ppsspp-1.15.ebuild b/games-emulation/ppsspp/ppsspp-1.15.ebuild
new file mode 100644
index 000000000000..9653b9ec6119
--- /dev/null
+++ b/games-emulation/ppsspp/ppsspp-1.15.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit python-any-r1 xdg cmake
+
+DESCRIPTION="A PSP emulator written in C++"
+HOMEPAGE="https://www.ppsspp.org/
+ https://github.com/hrydgard/ppsspp/"
+SRC_URI="https://github.com/hrydgard/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 GPL-2 JSON MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="discord qt5"
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/snappy:=
+ app-arch/zstd:=
+ dev-libs/libzip:=
+ media-libs/glew:=
+ media-libs/libpng:=
+ media-libs/libsdl2[joystick]
+ media-video/ffmpeg:0/56.58.58
+ sys-libs/zlib:=
+ virtual/opengl
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[-gles2-only]
+ dev-qt/qtmultimedia:5[-gles2-only]
+ dev-qt/qtopengl:5[-gles2-only]
+ dev-qt/qtwidgets:5[-gles2-only]
+ )
+ !qt5? ( media-libs/libsdl2[X,opengl,sound,video] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-CMakeLists-flags.patch
+ "${FILESDIR}"/${PN}-disable-ccache-autodetection.patch
+)
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ -DCMAKE_SKIP_RPATH=ON
+ -DHEADLESS=false
+ -DUSE_SYSTEM_FFMPEG=ON
+ -DUSE_SYSTEM_LIBZIP=ON
+ -DUSE_SYSTEM_SNAPPY=ON
+ -DUSE_SYSTEM_ZSTD=ON
+ -DUSE_DISCORD=$(usex discord)
+ -DUSING_QT_UI=$(usex qt5)
+ )
+ cmake_src_configure
+}