summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-engines/gemrb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-engines/gemrb')
-rw-r--r--games-engines/gemrb/Manifest1
-rw-r--r--games-engines/gemrb/gemrb-0.8.2.ebuild79
-rw-r--r--games-engines/gemrb/metadata.xml8
3 files changed, 88 insertions, 0 deletions
diff --git a/games-engines/gemrb/Manifest b/games-engines/gemrb/Manifest
new file mode 100644
index 000000000000..b414d753b1ac
--- /dev/null
+++ b/games-engines/gemrb/Manifest
@@ -0,0 +1 @@
+DIST gemrb-0.8.2.tar.gz 12302710 SHA256 57cc267f730d205774fa5a6db1f0dd88b97a8193dbece905d70cb50e433774ee SHA512 2a666537ca540f041122bcd1117cf591c5a223480a5c4c18eebaef6b446fc355c6078d54fcbc3a89b8ba35d7ecbaf53648394e383f0479e84da999fccea1f496 WHIRLPOOL 4ad8a39b937467e7e7a28dbae1d3d449789259124bb0be6dc916ef1396da9b3027ded802d906311ff53785288f423ae7d6fd4d3f339782fa259d6bb3de1c4a31
diff --git a/games-engines/gemrb/gemrb-0.8.2.ebuild b/games-engines/gemrb/gemrb-0.8.2.ebuild
new file mode 100644
index 000000000000..def837b4bd32
--- /dev/null
+++ b/games-engines/gemrb/gemrb-0.8.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+WANT_CMAKE=always
+inherit eutils python-any-r1 cmake-utils gnome2-utils games
+
+DESCRIPTION="Reimplementation of the Infinity engine"
+HOMEPAGE="http://gemrb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gemrb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/freetype
+ media-libs/libpng:0
+ >=media-libs/libsdl-1.2[video]
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/sdl-mixer
+ sys-libs/zlib
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e '/COPYING/d' \
+ CMakeLists.txt || die
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${GAMES_PREFIX}"
+ -DBIN_DIR="${GAMES_BINDIR}"
+ -DDATA_DIR="${GAMES_DATADIR}/gemrb"
+ -DSYSCONF_DIR="${GAMES_SYSCONFDIR}/gemrb"
+ -DLIB_DIR="$(games_get_libdir)"
+ -DMAN_DIR=/usr/share/man/man6
+ -DICON_DIR=/usr/share/pixmaps
+ -DMENU_DIR=/usr/share/applications
+ -DDOC_DIR="/usr/share/doc/${PF}"
+ -DSVG_DIR=/usr/share/icons/hicolor/scalable/apps
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc README NEWS AUTHORS
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-engines/gemrb/metadata.xml b/games-engines/gemrb/metadata.xml
new file mode 100644
index 000000000000..3e4eb6496d81
--- /dev/null
+++ b/games-engines/gemrb/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">gemrb</remote-id>
+ </upstream>
+</pkgmetadata>