summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-03-20 13:32:04 +0000
committerJames Le Cuirot <chewi@gentoo.org>2022-03-20 13:32:04 +0000
commitc4f11054b952425eaa64895a0e728b8d1925c84d (patch)
tree66f70cd13d7957769e0a0246184fa469998080b7 /games-engines/odamex
parentgames-engines/odamex: Patch fix USE=master breakage on newer compilers (diff)
downloadgentoo-c4f11054b952425eaa64895a0e728b8d1925c84d.tar.gz
gentoo-c4f11054b952425eaa64895a0e728b8d1925c84d.tar.bz2
gentoo-c4f11054b952425eaa64895a0e728b8d1925c84d.zip
games-engines/odamex: Drop old 0.9.5
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-engines/odamex')
-rw-r--r--games-engines/odamex/Manifest1
-rw-r--r--games-engines/odamex/files/odamex-0.9.0-Unbundle-miniupnpc.patch80
-rw-r--r--games-engines/odamex/odamex-0.9.5.ebuild79
3 files changed, 0 insertions, 160 deletions
diff --git a/games-engines/odamex/Manifest b/games-engines/odamex/Manifest
index b2e65dadb436..cf41cb20eab0 100644
--- a/games-engines/odamex/Manifest
+++ b/games-engines/odamex/Manifest
@@ -1,2 +1 @@
-DIST odamex-0.9.5.tar.bz2 6659528 BLAKE2B 6f6052aff5a1e0c9a54c417113b67a91044d05ebf13d8ab5fb01132f9bb90b1c97392e881b8bff8baee4621c8e53abbb360fc8c7e6de8ff53d45ee55f73c48ec SHA512 70a0deb5e5b5902620f8fe692dc8507f9f19d7d6afabb4e2efbc25dc6879d469aa250dc55bb165db83a4288af9d5adda72ce3823a3db6dd9ccb83f5c684d3ac8
DIST odamex-src-10.0.0.tar.xz 17680868 BLAKE2B 95df336ccc24c2658174bdd051cb9b98ca906d653d84a120330d8fe6f11ad91ba70ba7edfc960f8815d02795f7392761a0174171de30ea78b37389a61deacae7 SHA512 b825953a446a4eb46d2d004b20df876bceec823cb5f0bf661ecac03eff2f07c11fe47c6861f3c3ee417ce9ca869474ff422d78bba1b742485315ba5ba86bd702
diff --git a/games-engines/odamex/files/odamex-0.9.0-Unbundle-miniupnpc.patch b/games-engines/odamex/files/odamex-0.9.0-Unbundle-miniupnpc.patch
deleted file mode 100644
index 77b6220041da..000000000000
--- a/games-engines/odamex/files/odamex-0.9.0-Unbundle-miniupnpc.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-From 4b9a8ca565e5cd388a49cd0fbe693b5332577c57 Mon Sep 17 00:00:00 2001
-From: William Breathitt Gray <vilhelm.gray@gmail.com>
-Date: Mon, 22 Mar 2021 18:20:15 +0900
-Subject: [PATCH] Unbundle miniupnpc
-
----
- libraries/CMakeLists.txt | 42 ----------------------------------------
- server/CMakeLists.txt | 3 ++-
- 2 files changed, 2 insertions(+), 43 deletions(-)
-
-diff --git a/libraries/CMakeLists.txt b/libraries/CMakeLists.txt
-index 177a86a2..2ffe95a5 100644
---- a/libraries/CMakeLists.txt
-+++ b/libraries/CMakeLists.txt
-@@ -227,48 +227,6 @@ endif()
-
- ### MiniUPnPc ###
-
--if(BUILD_SERVER)
-- message(STATUS "Compiling MiniUPnPc...")
--
-- # Figure out the correct library path to attach to our imported target
-- set(MINIUPNPC_INCLUDE_DIR
-- "${CMAKE_CURRENT_BINARY_DIR}/local/include/miniupnpc")
-- set(MINIUPNPC_LIBRARY
-- "${CMAKE_CURRENT_BINARY_DIR}/local/lib/${libprefix}miniupnpc${libsuffix}")
--
-- # This must exist before the target is synthesized.
-- file(MAKE_DIRECTORY ${MINIUPNPC_INCLUDE_DIR})
--
-- # Generate the build.
-- execute_process(COMMAND "${CMAKE_COMMAND}"
-- -S "${CMAKE_CURRENT_SOURCE_DIR}/libminiupnpc"
-- -B "${CMAKE_CURRENT_BINARY_DIR}/libminiupnpc-build"
-- -G "${CMAKE_GENERATOR}"
-- -A "${CMAKE_GENERATOR_PLATFORM}"
-- -T "${CMAKE_GENERATOR_TOOLSET}"
-- "-DCMAKE_C_COMPILER=${CMAKE_C_COMPILER}"
-- "-DCMAKE_LINKER=${CMAKE_LINKER}"
-- "-DCMAKE_RC_COMPILER=${CMAKE_RC_COMPILER}"
-- "-DCMAKE_BUILD_TYPE=RelWithDebInfo"
-- "-DCMAKE_INSTALL_PREFIX=${CMAKE_CURRENT_BINARY_DIR}/local"
-- "-DCMAKE_INSTALL_LIBDIR=lib" # Without this, CentOS installs into lib64
-- "-DUPNPC_BUILD_SHARED=No"
-- "-DUPNPC_BUILD_TESTS=No")
--
-- # Compile the library.
-- execute_process(COMMAND "${CMAKE_COMMAND}"
-- --build "${CMAKE_CURRENT_BINARY_DIR}/libminiupnpc-build"
-- --config RelWithDebInfo --target install --parallel ${PARALLEL_PROC_COUNT})
--
-- # Synthesize an imported target that can be linked against.
-- add_library(upnpc-static STATIC IMPORTED GLOBAL)
-- set_target_properties(upnpc-static PROPERTIES
-- INTERFACE_INCLUDE_DIRECTORIES "${MINIUPNPC_INCLUDE_DIR}"
-- IMPORTED_LOCATION ${MINIUPNPC_LIBRARY})
-- if(WIN32)
-- set_target_properties(upnpc-static PROPERTIES INTERFACE_LINK_LIBRARIES "ws2_32;iphlpapi")
-- endif()
--endif()
-
- ### SDL libraries ###
-
-diff --git a/server/CMakeLists.txt b/server/CMakeLists.txt
-index 73a70000..e4b085f2 100644
---- a/server/CMakeLists.txt
-+++ b/server/CMakeLists.txt
-@@ -53,7 +53,8 @@ endif()
- target_link_libraries(odasrv jsoncpp odamex-common)
-
- if(USE_MINIUPNP)
-- target_link_libraries(odasrv upnpc-static)
-+ target_include_directories(odasrv SYSTEM PRIVATE "/usr/include/miniupnpc")
-+ target_link_libraries(odasrv -lminiupnpc)
- endif()
-
- if(WIN32)
---
-2.31.0
-
diff --git a/games-engines/odamex/odamex-0.9.5.ebuild b/games-engines/odamex/odamex-0.9.5.ebuild
deleted file mode 100644
index eb8519c9e40f..000000000000
--- a/games-engines/odamex/odamex-0.9.5.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-WX_GTK_VER="3.0-gtk3"
-inherit cmake desktop prefix wxwidgets xdg
-
-DESCRIPTION="Online multiplayer free software engine for DOOM"
-HOMEPAGE="https://odamex.net/"
-SRC_URI="mirror://sourceforge/${PN}/Odamex/${PV}/${PN}-src-${PV}.tar.bz2 -> ${P}.tar.bz2"
-
-LICENSE="GPL-2+ MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+client master +odalaunch portmidi server upnp X"
-REQUIRED_USE="|| ( client master server )"
-
-RDEPEND="
- client? (
- media-libs/libpng:0=
- media-libs/libsdl2[joystick,sound,video]
- media-libs/sdl2-mixer
- net-misc/curl
- portmidi? ( media-libs/portmidi )
- X? ( x11-libs/libX11 )
- )
- odalaunch? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
- server? (
- upnp? ( net-libs/miniupnpc:= )
- )"
-DEPEND="${RDEPEND}"
-BDEPEND="games-util/deutex"
-
-S="${WORKDIR}/${PN}-src-${PV}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.9.0-Unbundle-miniupnpc.patch"
- "${FILESDIR}/${PN}-10.0.0-musl.patch"
-)
-
-src_prepare() {
- rm -r libraries/libminiupnpc || die
- hprefixify common/d_main.cpp
-
- use odalaunch && setup-wxwidgets
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_INTERNAL_LIBS=0
- -DBUILD_CLIENT=$(usex client)
- -DBUILD_LAUNCHER=$(usex odalaunch)
- -DBUILD_MASTER=$(usex master)
- -DBUILD_SERVER=$(usex server)
- -DBUILD_OR_FAIL=1
- -DENABLE_PORTMIDI=$(usex portmidi)
- -DUSE_MINIUPNP=$(usex upnp)
- )
- use client && mycmakeargs+=(-DCMAKE_DISABLE_FIND_PACKAGE_X11=$(usex !X))
-
- cmake_src_configure
-}
-
-src_install() {
- if use client ; then
- newicon -s 128 "${S}/media/icon_${PN}_128.png" "${PN}.png"
- make_desktop_entry "${PN}" "Odamex"
-
- if use odalaunch ; then
- newicon -s 128 "${S}/media/icon_odalaunch_128.png" "odalaunch.png"
- make_desktop_entry odalaunch "Odamex Launcher" odalaunch
- fi
- fi
-
- cmake_src_install
-}