summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-03-17 21:14:26 +0000
committerJames Le Cuirot <chewi@gentoo.org>2018-03-17 21:27:36 +0000
commitc2604083a27e801f8643835d43fefbf846e9f434 (patch)
tree8fa15dbdad85bee2432d5b7d3a5b3232ac768361 /games-engines
parentmedia-video/simplescreenrecorder: Removed old. (diff)
downloadgentoo-c2604083a27e801f8643835d43fefbf846e9f434.tar.gz
gentoo-c2604083a27e801f8643835d43fefbf846e9f434.tar.bz2
gentoo-c2604083a27e801f8643835d43fefbf846e9f434.zip
games-engines/openxcom: Fix 9999 icons and desktop file installation
sed broke CMakeLists.txt but this is no longer necessary anyway as upstream now use GNUInstallDirs. Closes: https://bugs.gentoo.org/623058 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/openxcom/openxcom-9999.ebuild24
1 files changed, 4 insertions, 20 deletions
diff --git a/games-engines/openxcom/openxcom-9999.ebuild b/games-engines/openxcom/openxcom-9999.ebuild
index 6732dfdefa91..746a5950a0a8 100644
--- a/games-engines/openxcom/openxcom-9999.ebuild
+++ b/games-engines/openxcom/openxcom-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils cmake-utils gnome2-utils git-r3
+inherit cmake-utils gnome2-utils git-r3
DESCRIPTION="An open-source reimplementation of the popular UFO: Enemy Unknown"
HOMEPAGE="http://openxcom.org/"
@@ -21,18 +21,7 @@ RDEPEND=">=dev-cpp/yaml-cpp-0.5.1
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
-src_unpack() {
- git-r3_src_unpack
-}
-
-src_prepare() {
- cmake-utils_src_prepare
- sed -i -e '/\/res\//d' CMakeLists.txt || die
-}
-
-src_configure() {
- cmake-utils_src_configure
-}
+DOCS=( README.md )
src_compile() {
use doc && cmake-utils_src_compile doxygen
@@ -40,13 +29,8 @@ src_compile() {
}
src_install() {
- DOCS="README.md" \
- cmake-utils_src_install
+ cmake-utils_src_install
use doc && dodoc -r "${CMAKE_BUILD_DIR}"/docs/html/*
- doicon -s scalable res/linux/icons/openxcom.svg
- newicon -s 48 res/linux/icons/openxcom_48x48.png openxcom.png
- newicon -s 128 res/linux/icons/openxcom_128x128.png openxcom.png
- domenu res/linux/openxcom.desktop
}
pkg_preinst() {