summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-15 22:53:35 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-15 22:53:51 +0100
commitd5f1692b30355f9ebf076f7d94b51671de875820 (patch)
treee0aa322fec6bc0823b373978052432eb49d45bc3 /games-engines
parentgames-engines/residualvm: Revbump to fix freetype detection (diff)
downloadgentoo-d5f1692b30355f9ebf076f7d94b51671de875820.tar.gz
gentoo-d5f1692b30355f9ebf076f7d94b51671de875820.tar.bz2
gentoo-d5f1692b30355f9ebf076f7d94b51671de875820.zip
games-engines/residualvm: Synced live ebuild.
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/residualvm/residualvm-9999.ebuild30
1 files changed, 12 insertions, 18 deletions
diff --git a/games-engines/residualvm/residualvm-9999.ebuild b/games-engines/residualvm/residualvm-9999.ebuild
index 7343afbb7e72..d263427ea17f 100644
--- a/games-engines/residualvm/residualvm-9999.ebuild
+++ b/games-engines/residualvm/residualvm-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit gnome2-utils toolchain-funcs xdg-utils
+EAPI=7
+inherit desktop toolchain-funcs xdg
DESCRIPTION="A cross-platform 3D game interpreter for play LucasArts' LUA-based 3D adventures"
HOMEPAGE="http://www.residualvm.org/"
@@ -25,11 +25,14 @@ RDEPEND="
media-libs/glew:0=
media-libs/libpng:0=
media-libs/libsdl2[X,sound,alsa,joystick,opengl,video]
- sys-libs/zlib
+ sys-libs/zlib:=
virtual/glu
virtual/jpeg:0
virtual/opengl"
DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
src_configure() {
# not an autotools script
@@ -51,6 +54,7 @@ src_configure() {
--enable-all-engines
--enable-release-mode
--enable-zlib
+ --prefix="${EPREFIX}/usr"
)
./configure "${myconf[@]}" || die "configure failed"
}
@@ -63,29 +67,19 @@ src_compile() {
}
src_install() {
- dobin residualvm
+ emake DESTDIR="${D}" install
- insinto "/usr/share/${PN}"
- doins gui/themes/modern.zip dists/engine-data/residualvm-grim-patch.lab
-
- doicon -s scalable icons/${PN}.svg
doicon -s 256 icons/${PN}.png
- domenu dists/${PN}.desktop
-
- doman dists/${PN}.6
- dodoc AUTHORS README.md KNOWN_BUGS TODO
}
pkg_preinst() {
- gnome2_icon_savelist
+ xdg_pkg_preinst
}
pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
+ xdg_pkg_postinst
}
pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
+ xdg_pkg_postrm
}