summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-02-08 12:13:15 -0600
committerAustin English <wizardedit@gentoo.org>2017-02-09 11:35:52 -0600
commitee09b63d6dc5dd3408983d0f9b01477af3d9aed4 (patch)
tree8c20515dbd0720938b9f39f28a4c061df1baaae2 /games-fps/quakeforge
parentdev-python/jinja: Removed old. (diff)
downloadgentoo-ee09b63d6dc5dd3408983d0f9b01477af3d9aed4.tar.gz
gentoo-ee09b63d6dc5dd3408983d0f9b01477af3d9aed4.tar.bz2
gentoo-ee09b63d6dc5dd3408983d0f9b01477af3d9aed4.zip
games-fps/quakeforge: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: Portage-2.3.2, Repoman-2.3.1
Diffstat (limited to 'games-fps/quakeforge')
-rw-r--r--games-fps/quakeforge/files/quakeforge-0.7.2-gentoo.patch12
-rw-r--r--games-fps/quakeforge/quakeforge-0.7.2-r1.ebuild127
2 files changed, 133 insertions, 6 deletions
diff --git a/games-fps/quakeforge/files/quakeforge-0.7.2-gentoo.patch b/games-fps/quakeforge/files/quakeforge-0.7.2-gentoo.patch
index 396d7322b453..38fb0c187689 100644
--- a/games-fps/quakeforge/files/quakeforge-0.7.2-gentoo.patch
+++ b/games-fps/quakeforge/files/quakeforge-0.7.2-gentoo.patch
@@ -1,5 +1,5 @@
---- nq/source/Makefile.am.old 2012-11-18 16:57:56.658388682 +0100
-+++ nq/source/Makefile.am 2012-11-18 16:58:11.470268607 +0100
+--- a/nq/source/Makefile.am 2012-11-18 16:57:56.658388682 +0100
++++ b/nq/source/Makefile.am 2012-11-18 16:58:11.470268607 +0100
@@ -138,7 +138,7 @@
nq_x11_SOURCES= sys_unix.c
nq_x11_LDADD= $(nq_x11_libs) \
@@ -9,8 +9,8 @@
nq_x11_LDFLAGS= $(common_ldflags)
nq_x11_DEPENDENCIES= $(nq_x11_libs)
---- qw/source/Makefile.am.old 2012-11-18 17:10:59.148172332 +0100
-+++ qw/source/Makefile.am 2012-11-18 17:11:55.866876762 +0100
+--- a/qw/source/Makefile.am 2012-11-18 17:10:59.148172332 +0100
++++ b/qw/source/Makefile.am 2012-11-18 17:11:55.866876762 +0100
@@ -168,7 +168,7 @@
qw_client_x11_SOURCES= cl_sys_unix.c
qw_client_x11_LDADD= $(qw_client_x11_libs) \
@@ -20,8 +20,8 @@
qw_client_x11_LDFLAGS= $(common_ldflags)
qw_client_x11_DEPENDENCIES= $(qw_client_x11_libs)
---- tools/qwaq/Makefile.am.old 2012-11-18 17:15:16.024714317 +0100
-+++ tools/qwaq/Makefile.am 2012-11-18 17:15:41.955749660 +0100
+--- a/tools/qwaq/Makefile.am 2012-11-18 17:15:16.024714317 +0100
++++ b/tools/qwaq/Makefile.am 2012-11-18 17:15:41.955749660 +0100
@@ -38,7 +38,7 @@
qwaq_x11_SOURCES=qwaq.c qwaq-bi.c
qwaq_x11_LDADD= $(qwaq_x11_libs) $(QWAQ_LIBS) \
diff --git a/games-fps/quakeforge/quakeforge-0.7.2-r1.ebuild b/games-fps/quakeforge/quakeforge-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..5762daa8e536
--- /dev/null
+++ b/games-fps/quakeforge/quakeforge-0.7.2-r1.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="New 3d engine based off of id Softwares's Quake and QuakeWorld game engine"
+HOMEPAGE="http://www.quakeforge.net/"
+SRC_URI="mirror://sourceforge/quake/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa cdinstall debug dga fbcon flac ipv6 ncurses oss png sdl vorbis wildmidi X xdg xv zlib"
+RESTRICT="userpriv"
+
+RDEPEND="
+ media-libs/libsamplerate
+ net-misc/curl
+ virtual/opengl
+ alsa? ( media-libs/alsa-lib )
+ dga? ( x11-libs/libXxf86dga )
+ flac? ( media-libs/flac )
+ ncurses? ( sys-libs/ncurses:0 )
+ png? ( media-libs/libpng:0 )
+ sdl? ( media-libs/libsdl[video] )
+ vorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+ wildmidi? ( media-sound/wildmidi )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86vm
+ )
+ xv? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86vm
+ )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ cdinstall? ( games-fps/quake1-data )
+ >=sys-devel/bison-2.6
+ sys-devel/flex
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+ append-cflags -std=gnu89 # build with gcc5 (bug #570392)
+}
+
+src_configure() {
+ local debugopts
+ use debug \
+ && debugopts="--enable-debug --disable-optimize --enable-profile" \
+ || debugopts="--disable-debug --disable-profile"
+
+ local clients=${QF_CLIENTS}
+ use fbcon && clients="${clients},fbdev"
+ use sdl && clients="${clients},sdl"
+ use X && clients="${clients},x11"
+ [ "${clients:0:1}" == "," ] && clients=${clients:1}
+
+ local servers=${QF_SERVERS:-master,nq,qw,qtv}
+
+ local tools=${QF_TOOLS:-all}
+
+ econf \
+ --enable-dependency-tracking \
+ $(use_enable ncurses curses) \
+ $(use_enable vorbis) \
+ $(use_enable png) \
+ $(use_enable zlib) \
+ $(use_with ipv6) \
+ $(use_with fbcon fbdev) \
+ $(use_with X x) \
+ $(use_enable xv vidmode) \
+ $(use_enable dga) \
+ $(use_enable sdl) \
+ --disable-xmms \
+ $(use_enable alsa) \
+ $(use_enable flac) \
+ $(use_enable oss) \
+ $(use_enable xdg) \
+ $(use_enable wildmidi) \
+ --enable-sound \
+ --disable-optimize \
+ --disable-Werror \
+ --without-svga \
+ ${debugopts} \
+ --with-global-cfg=/etc/quakeforge.conf \
+ --with-sharepath=/usr/share/quake1 \
+ --with-clients=${clients} \
+ --with-servers=${servers} \
+ --with-tools=${tools}
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ dodoc ChangeLog NEWS TODO
+}
+
+pkg_postinst() {
+ # same warning used in quake1 / quakeforge / nprquake-sdl
+ echo
+ elog "Before you can play, you must make sure"
+ elog "${PN} can find your Quake .pak files"
+ elog
+ elog "You have 2 choices to do this"
+ elog "1 Copy pak*.pak files to /usr/share/quake1/id1"
+ elog "2 Symlink pak*.pak files in /usr/share/quake1/id1"
+ elog
+ elog "Example:"
+ elog "my pak*.pak files are in /mnt/secondary/Games/Quake/Id1/"
+ elog "ln -s /mnt/secondary/Games/Quake/Id1/pak0.pak /usr/share/quake1/id1/pak0.pak"
+ elog
+ elog "You only need pak0.pak to play the demo version,"
+ elog "the others are needed for registered version"
+}