summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2017-07-16 22:58:37 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-07-16 23:02:30 +0200
commitfb783bc49c404ec6cc0405f872126b6bc2e78e31 (patch)
tree167b7f3be89ac6129ef807a6144cf18abf33d8fd /games-fps/urbanterror
parentprofiles/base/package.use.mask: Mask vaapi flag for www-plugins/gnash (diff)
downloadgentoo-fb783bc49c404ec6cc0405f872126b6bc2e78e31.tar.gz
gentoo-fb783bc49c404ec6cc0405f872126b6bc2e78e31.tar.bz2
gentoo-fb783bc49c404ec6cc0405f872126b6bc2e78e31.zip
games-fps/urbanterror: Cleanup old unused patches
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org> Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'games-fps/urbanterror')
-rw-r--r--games-fps/urbanterror/files/urbanterror-4.2.023-build.patch75
-rw-r--r--games-fps/urbanterror/files/urbanterror-4.2.023-nocurl.patch16
2 files changed, 0 insertions, 91 deletions
diff --git a/games-fps/urbanterror/files/urbanterror-4.2.023-build.patch b/games-fps/urbanterror/files/urbanterror-4.2.023-build.patch
deleted file mode 100644
index daa7e324a677..000000000000
--- a/games-fps/urbanterror/files/urbanterror-4.2.023-build.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-Author: hasufell <hasufell@gentoo.org>
-Date: Wed Jul 10 01:25:27 2013 +0200
-
- respect CFLAGS/LDFLAGS
-
---- a/Makefile
-+++ b/Makefile
-@@ -213,7 +213,7 @@
- endif
- endif
-
-- BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes -pipe
-+ BASE_CFLAGS = -Wall -Wimplicit -Wstrict-prototypes
-
- ifeq ($(USE_OPENAL),1)
- BASE_CFLAGS += -DUSE_OPENAL=1
-@@ -239,19 +239,15 @@
- BASE_CFLAGS += -I/usr/X11R6/include
- endif
-
-- OPTIMIZE = -O3 -ffast-math -funroll-loops -fomit-frame-pointer
-+ OPTIMIZE =
-
- ifeq ($(ARCH),x86_64)
-- OPTIMIZE = -O3 -fomit-frame-pointer -ffast-math -funroll-loops \
-- -falign-loops=2 -falign-jumps=2 -falign-functions=2 \
-- -fstrength-reduce
-+ OPTIMIZE =
- # experimental x86_64 jit compiler! you need GNU as
- HAVE_VM_COMPILED = true
- else
- ifeq ($(ARCH),i386)
-- OPTIMIZE = -O3 -march=i586 -fomit-frame-pointer -ffast-math \
-- -funroll-loops -falign-loops=2 -falign-jumps=2 \
-- -falign-functions=2 -fstrength-reduce
-+ OPTIMIZE =
- HAVE_VM_COMPILED=true
- else
- ifeq ($(ARCH),ppc)
-@@ -265,7 +261,7 @@
- BASE_CFLAGS += -DNO_VM_COMPILED
- endif
-
-- DEBUG_CFLAGS = $(BASE_CFLAGS) -g -O0
-+ DEBUG_CFLAGS = $(BASE_CFLAGS) $(OPTIMIZE)
-
- RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG $(OPTIMIZE)
-
-@@ -274,7 +270,7 @@
- SHLIBLDFLAGS=-shared $(LDFLAGS)
-
- THREAD_LDFLAGS=-lpthread
-- LDFLAGS=-ldl -lm
-+ LDFLAGS+=-ldl -lm
-
- ifeq ($(USE_SDL),1)
- CLIENT_LDFLAGS=$(shell sdl-config --libs)
-@@ -1158,13 +1154,13 @@
-
- $(B)/Quake3-UrT.$(ARCH)$(BINEXT): $(Q3OBJ) $(Q3POBJ) $(LIBSDLMAIN)
- $(echo_cmd) "LD $@"
-- $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ) $(CLIENT_LDFLAGS) \
-- $(LDFLAGS) $(LIBSDLMAIN)
-+ $(Q)$(CC) $(CFLAGS) -o $@ $(Q3OBJ) $(Q3POBJ) \
-+ $(LDFLAGS) $(CLIENT_LDFLAGS) $(LIBSDLMAIN)
-
- $(B)/Quake3-UrT-smp.$(ARCH)$(BINEXT): $(Q3OBJ) $(Q3POBJ_SMP) $(LIBSDLMAIN)
- $(echo_cmd) "LD $@"
-- $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) $(CLIENT_LDFLAGS) \
-- $(THREAD_LDFLAGS) $(LDFLAGS) $(LIBSDLMAIN)
-+ $(Q)$(CC) $(CFLAGS) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) \
-+ $(LDFLAGS) $(THREAD_LDFLAGS) $(CLIENT_LDFLAGS) $(LIBSDLMAIN)
-
- ifneq ($(strip $(LIBSDLMAIN)),)
- ifneq ($(strip $(LIBSDLMAINSRC)),)
diff --git a/games-fps/urbanterror/files/urbanterror-4.2.023-nocurl.patch b/games-fps/urbanterror/files/urbanterror-4.2.023-nocurl.patch
deleted file mode 100644
index b7d1f3106420..000000000000
--- a/games-fps/urbanterror/files/urbanterror-4.2.023-nocurl.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-fix building when USE=-curl is specified (bug #572074)
-
---- ./code/client/cl_main.c.orig
-+++ ./code/client/cl_main.c
-@@ -1872,7 +1872,11 @@
- }
-
- qboolean CL_IsDownloading(void) {
-+#if USE_CURL
- return clc.cURLUsed;
-+#else
-+ return qfalse;
-+#endif
- }
-
- /*