summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 11:31:35 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:31:39 +0200
commit8b39b338b261e7d0a72ea816eb47b32c9b17e793 (patch)
tree99392a89ebdbfa7f28b6aae0021c81ead3a4006b /games-fps/worldofpadman
parentgames-fps/transfusion-bin: Drop old (diff)
downloadgentoo-8b39b338b261e7d0a72ea816eb47b32c9b17e793.tar.gz
gentoo-8b39b338b261e7d0a72ea816eb47b32c9b17e793.tar.bz2
gentoo-8b39b338b261e7d0a72ea816eb47b32c9b17e793.zip
games-fps/worldofpadman: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-fps/worldofpadman')
-rw-r--r--games-fps/worldofpadman/files/worldofpadman-1.6-gentoo.patch4
-rw-r--r--games-fps/worldofpadman/worldofpadman-1.6-r1.ebuild96
2 files changed, 98 insertions, 2 deletions
diff --git a/games-fps/worldofpadman/files/worldofpadman-1.6-gentoo.patch b/games-fps/worldofpadman/files/worldofpadman-1.6-gentoo.patch
index 04804563646d..d55e43ffcf52 100644
--- a/games-fps/worldofpadman/files/worldofpadman-1.6-gentoo.patch
+++ b/games-fps/worldofpadman/files/worldofpadman-1.6-gentoo.patch
@@ -1,5 +1,5 @@
---- Makefile.old 2012-04-26 21:40:25.277417417 +0200
-+++ Makefile 2012-04-26 21:43:34.300835150 +0200
+--- a/Makefile.old 2012-04-26 21:40:25.277417417 +0200
++++ b/Makefile 2012-04-26 21:43:34.300835150 +0200
@@ -344,11 +344,11 @@
endif
diff --git a/games-fps/worldofpadman/worldofpadman-1.6-r1.ebuild b/games-fps/worldofpadman/worldofpadman-1.6-r1.ebuild
new file mode 100644
index 000000000000..eced904caceb
--- /dev/null
+++ b/games-fps/worldofpadman/worldofpadman-1.6-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="A cartoon style multiplayer first-person shooter"
+HOMEPAGE="http://worldofpadman.net/"
+SRC_URI="mirror://sourceforge/${PN}/wop-1.5-unified.zip
+ mirror://sourceforge/${PN}/wop-1.5.x-to-1.6-patch-unified.zip"
+
+LICENSE="GPL-2 worldofpadman"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+curl dedicated maps +openal +theora +vorbis"
+
+RDEPEND="sys-libs/zlib
+ !dedicated? (
+ >=media-libs/speex-1.2.0
+ media-libs/speexdsp
+ virtual/jpeg:0
+ media-libs/libsdl[opengl,video,X]
+ virtual/opengl
+ virtual/glu
+ openal? ( media-libs/openal )
+ curl? ( net-misc/curl )
+ vorbis? ( media-libs/libvorbis )
+ theora? (
+ media-libs/libtheora
+ media-libs/libogg
+ )
+ )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+"
+
+S="${WORKDIR}/${P}_svn2178-src"
+
+src_unpack() {
+ unpack ${A}
+ unzip XTRAS/"editing files"/${P}-src.zip
+}
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e 's:JPEG_LIB_VERSION < 80:JPEG_LIB_VERSION < 62:' \
+ code/renderer/tr_image_jpg.c || die #479652
+}
+
+src_compile() {
+ local arch
+
+ if use amd64 ; then
+ arch=x86_64
+ elif use x86 ; then
+ arch=i386
+ fi
+
+ emake \
+ V=1 \
+ ARCH=${arch} \
+ BUILD_CLIENT=$(use dedicated && echo 0) \
+ DEFAULT_BASEDIR=/usr/share/${PN} \
+ OPTIMIZE= \
+ USE_CURL=$(usex curl 1 0) \
+ USE_CURL_DLOPEN=0 \
+ USE_OPENAL=$(usex openal 1 0) \
+ USE_OPENAL_DLOPEN=0 \
+ USE_CODEC_VORBIS=$(usex vorbis 1 0) \
+ USE_CIN_THEORA=$(usex theora 1 0) \
+ USE_RENDERER_DLOPEN=0 \
+ USE_INTERNAL_ZLIB=0 \
+ USE_INTERNAL_JPEG=0 \
+ USE_INTERNAL_SPEEX=0
+}
+
+src_install() {
+ newbin build/release-*/wopded.* ${PN}-ded
+ if ! use dedicated ; then
+ newbin build/release-*/wop.* ${PN}
+ newicon misc/quake3.png ${PN}.png
+ make_desktop_entry ${PN} "World of Padman"
+ fi
+ insinto /usr/share/${PN}
+ doins -r ../wop
+
+ dodoc id-readme.txt \
+ IOQ3-README \
+ voip-readme.txt \
+ ../XTRAS/changelog.txt \
+ ../XTRAS/sounds_readme.txt
+ HTML_DOCS="../XTRAS/readme ../XTRAS/readme.html" einstalldocs
+}