summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-10-11 16:31:07 -0500
committerAustin English <wizardedit@gentoo.org>2016-10-11 17:55:47 -0500
commit51116b3ebaea7e94ce6f11a3ae15c066ad5aa84d (patch)
treea1491b51b4fc7ca5a11248b54030f1a671be29b9 /games-misc/gtklife
parentgames-misc/lucidlife: remove deprecated games eclass (diff)
downloadgentoo-51116b3ebaea7e94ce6f11a3ae15c066ad5aa84d.tar.gz
gentoo-51116b3ebaea7e94ce6f11a3ae15c066ad5aa84d.tar.bz2
gentoo-51116b3ebaea7e94ce6f11a3ae15c066ad5aa84d.zip
games-misc/nyancat: remove deprecated games eclass
Version bump to 1.5.1 Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-misc/gtklife')
-rw-r--r--games-misc/gtklife/gtklife-5.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-misc/gtklife/gtklife-5.1-r1.ebuild b/games-misc/gtklife/gtklife-5.1-r1.ebuild
new file mode 100644
index 000000000000..a0a40195e8f9
--- /dev/null
+++ b/games-misc/gtklife/gtklife-5.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="A Conway's Life simulator for Unix"
+HOMEPAGE="http://ironphoenix.org/tril/gtklife/"
+SRC_URI="http://ironphoenix.org/tril/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-link.patch
+)
+
+src_configure() {
+ econf \
+ --with-gtk2 \
+ --with-docdir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ dobin ${PN}
+
+ insinto /usr/share/${PN}
+ doins -r graphics patterns
+
+ newicon icon_48x48.png ${PN}.png
+ make_desktop_entry ${PN} GtkLife
+
+ dodoc -r doc/*
+ dodoc AUTHORS README NEWS
+}