summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-misc/xpenguins
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-misc/xpenguins')
-rw-r--r--games-misc/xpenguins/Manifest2
-rw-r--r--games-misc/xpenguins/metadata.xml5
-rw-r--r--games-misc/xpenguins/xpenguins-2.2-r1.ebuild27
3 files changed, 34 insertions, 0 deletions
diff --git a/games-misc/xpenguins/Manifest b/games-misc/xpenguins/Manifest
new file mode 100644
index 000000000000..f8dc969b8996
--- /dev/null
+++ b/games-misc/xpenguins/Manifest
@@ -0,0 +1,2 @@
+DIST xpenguins-2.2.tar.gz 275210 SHA256 60881bac15419aa2875fb56f0c1d8fbdb12c5083db0e1e761436178baa86117e SHA512 cb24e17a5a19df0de162b2214dec2fbfc07396cdea9d138b8426d8fc38e248b1faba65ebfb8ba74a5cf515063ba8f4032c4588586b23b5be6aa0a208cfcfebf1 WHIRLPOOL 3b1b176306109d5839cd230e00b5486ea6fa2a1466b0926ee1261dab2d30f657e07bb4cc53c747b79b2a92f935eb79ff9903db3161a2a46fbd2786da3aa3ec88
+DIST xpenguins_themes-1.0.tar.gz 215487 SHA256 d6aeee8c7b0c5a02b187cbe1d781341576d711a25f837c75e11f997a92e9a957 SHA512 577dedccfff8f4581c9285deb809d43a09631e15461783bfb5f00d2bf0e687d54f04ad3bcf1051113777d74f57c94c278b99749265a3efe8ebc6aabb1501eaf8 WHIRLPOOL 97c1df45c75aa74b77915844cfa43461b75f8e5ac5d7576076dd4477c9bdb33b03e1f8c0cd93d23375b36bb829f16002541d6223823564c1b472f97eee864bae
diff --git a/games-misc/xpenguins/metadata.xml b/games-misc/xpenguins/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-misc/xpenguins/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-misc/xpenguins/xpenguins-2.2-r1.ebuild b/games-misc/xpenguins/xpenguins-2.2-r1.ebuild
new file mode 100644
index 000000000000..98d956c2fc4a
--- /dev/null
+++ b/games-misc/xpenguins/xpenguins-2.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+inherit games
+
+THEMES_VERSION="1.0"
+DESCRIPTION="Cute little penguins invading your desktop"
+HOMEPAGE="http://xpenguins.seul.org/"
+SRC_URI="http://xpenguins.seul.org/${P}.tar.gz
+ http://xpenguins.seul.org/xpenguins_themes-${THEMES_VERSION}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+src_install() {
+ default
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r ../themes/
+ prepgamesdirs
+}