summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-08-05 14:27:50 -0500
committerAustin English <wizardedit@gentoo.org>2016-08-05 14:43:17 -0500
commitf9dc923b1a6689ba56d8ce7cce6809df18f46cda (patch)
tree740e502299b647c8fbc80e8f72687339452cfe56 /games-mud/tkmoo
parentgames-mud/tintin: remove deprecated games eclass (diff)
downloadgentoo-f9dc923b1a6689ba56d8ce7cce6809df18f46cda.tar.gz
gentoo-f9dc923b1a6689ba56d8ce7cce6809df18f46cda.tar.bz2
gentoo-f9dc923b1a6689ba56d8ce7cce6809df18f46cda.zip
games-mud/tkmoo: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-mud/tkmoo')
-rw-r--r--games-mud/tkmoo/files/0.3.32-Makefile-noclean.patch4
-rw-r--r--games-mud/tkmoo/files/0.3.32-keys-workaround.patch4
-rw-r--r--games-mud/tkmoo/tkmoo-0.3.32-r1.ebuild46
3 files changed, 50 insertions, 4 deletions
diff --git a/games-mud/tkmoo/files/0.3.32-Makefile-noclean.patch b/games-mud/tkmoo/files/0.3.32-Makefile-noclean.patch
index c61a29df0ac8..cebc1fecfc34 100644
--- a/games-mud/tkmoo/files/0.3.32-Makefile-noclean.patch
+++ b/games-mud/tkmoo/files/0.3.32-Makefile-noclean.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2003-07-12 03:04:24.000000000 -0400
-+++ Makefile 2003-07-12 03:04:32.000000000 -0400
+--- a/Makefile 2003-07-12 03:04:24.000000000 -0400
++++ b/Makefile 2003-07-12 03:04:32.000000000 -0400
@@ -32,11 +32,8 @@
# some shells are set 'noclobber', so force overwriting of the
diff --git a/games-mud/tkmoo/files/0.3.32-keys-workaround.patch b/games-mud/tkmoo/files/0.3.32-keys-workaround.patch
index d70e017f09e4..db8886ed4b61 100644
--- a/games-mud/tkmoo/files/0.3.32-keys-workaround.patch
+++ b/games-mud/tkmoo/files/0.3.32-keys-workaround.patch
@@ -1,5 +1,5 @@
---- source.tcl.orig 2004-12-28 23:36:47.000000000 -0800
-+++ source.tcl 2004-12-28 23:37:09.000000000 -0800
+--- a/source.tcl 2004-12-28 23:36:47.000000000 -0800
++++ b/source.tcl 2004-12-28 23:37:09.000000000 -0800
@@ -51,6 +51,10 @@
#
#
diff --git a/games-mud/tkmoo/tkmoo-0.3.32-r1.ebuild b/games-mud/tkmoo/tkmoo-0.3.32-r1.ebuild
new file mode 100644
index 000000000000..6664000b5133
--- /dev/null
+++ b/games-mud/tkmoo/tkmoo-0.3.32-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+MY_PN=${PN/moo/MOO-light}
+MY_P=${P/moo/MOO-light}
+DESCRIPTION="MOO Client written in Tcl/Tk"
+HOMEPAGE="http://www.awns.com/tkMOO-light/"
+SRC_URI="http://www.awns.com/tkMOO-light/Source/${MY_P}.tar.gz"
+
+LICENSE="tkMOO"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-lang/tcl-8.3.3:0=
+ >=dev-lang/tk-8.3.3:0="
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}/${PV}-Makefile-noclean.patch"
+ "${FILESDIR}/${PV}-keys-workaround.patch"
+)
+
+src_compile() {
+ emake \
+ WISH="$(type -P wish)" \
+ TKMOO_LIB_DIR="/usr/$(get_libdir)/${MY_PN}" \
+ TKMOO_BIN_DIR=/usr/bin
+}
+
+src_install() {
+ emake \
+ TKMOO_LIB_DIR="${D}/usr/$(get_libdir)/${MY_PN}" \
+ TKMOO_BIN_DIR="${D}/usr/bin" \
+ install
+ dodoc README dot.tkmoolightrc bugsmail.txt
+ dosym tkMOO-lite /usr/bin/tkmoo
+ make_desktop_entry tkmoo "tkMOO"
+}