summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-08-05 14:05:34 -0500
committerAustin English <wizardedit@gentoo.org>2016-08-05 14:43:17 -0500
commitbd106aea1605a4aff9948221455cdf9d0f75e79a (patch)
treedffbb2fd351222a45bd05a6b544ee1de4173b89d /games-mud
parentgames-mud/kildclient: remove deprecated games eclass (diff)
downloadgentoo-bd106aea1605a4aff9948221455cdf9d0f75e79a.tar.gz
gentoo-bd106aea1605a4aff9948221455cdf9d0f75e79a.tar.bz2
gentoo-bd106aea1605a4aff9948221455cdf9d0f75e79a.zip
games-mud/lyntin: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-mud')
-rw-r--r--games-mud/lyntin/lyntin-4.2-r2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/games-mud/lyntin/lyntin-4.2-r2.ebuild b/games-mud/lyntin/lyntin-4.2-r2.ebuild
new file mode 100644
index 000000000000..481a4be6ad48
--- /dev/null
+++ b/games-mud/lyntin/lyntin-4.2-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk?"
+
+inherit distutils-r1
+
+DESCRIPTION="tintin mud client clone implemented in Python"
+HOMEPAGE="http://lyntin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lyntin/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="tk"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+DOCS=( COMMANDS PKG-INFO HACKING README )
+
+python_install() {
+ distutils-r1_python_install --install-scripts=/usr/bin
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ if use tk ; then
+ elog "To start lyntin in GUI mode, create a config file"
+ elog "with this in it:"
+ elog
+ elog "[Lyntin]"
+ elog "ui: tk"
+ elog
+ elog "Then start lyntin like this:"
+ elog
+ elog "runlyntin -c /path/to/config_file\n"
+ fi
+}