summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/amoebax
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/amoebax')
-rw-r--r--games-puzzle/amoebax/Manifest1
-rw-r--r--games-puzzle/amoebax/amoebax-0.2.1.ebuild44
-rw-r--r--games-puzzle/amoebax/files/amoebax-0.2.1-aclocal.patch41
-rw-r--r--games-puzzle/amoebax/files/amoebax-0.2.1-compile.patch12
-rw-r--r--games-puzzle/amoebax/metadata.xml5
5 files changed, 103 insertions, 0 deletions
diff --git a/games-puzzle/amoebax/Manifest b/games-puzzle/amoebax/Manifest
new file mode 100644
index 000000000000..557b6360db74
--- /dev/null
+++ b/games-puzzle/amoebax/Manifest
@@ -0,0 +1 @@
+DIST amoebax-0.2.1.tar.bz2 10645579 SHA256 709c7e657b328a6f7d331298c6264f172528489d28cab107c40c483c392340b2 SHA512 f8cd20cb35e2456487f55ebc89411ebd47b25cf549d35c36041a27e1d96ef30702151f303dbb457afbf8583f67c53143c30becdea00a26fddad20555e0c7d181 WHIRLPOOL eafcdf27b852b226db86f162b14665d5d6f5bc5e539b1c5cefe698380fbf6fe378cdf86de2e023f51cda5e3846a134b21b509180ac257d85b446bfb33d4f6104
diff --git a/games-puzzle/amoebax/amoebax-0.2.1.ebuild b/games-puzzle/amoebax/amoebax-0.2.1.ebuild
new file mode 100644
index 000000000000..6c7ada024569
--- /dev/null
+++ b/games-puzzle/amoebax/amoebax-0.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="a cute and addictive action-puzzle game, similar to tetris"
+HOMEPAGE="http://www.emma-soft.com/games/amoebax/"
+SRC_URI="http://www.emma-soft.com/games/amoebax/download/${P}.tar.bz2"
+
+LICENSE="FreeArt GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-aclocal.patch \
+ "${FILESDIR}"/${P}-compile.patch
+
+ sed -i \
+ -e "/^SUBDIRS/s:doc ::" \
+ Makefile.am || die
+ sed -i \
+ -e "/^iconsdir/s:=.*:=/usr/share/pixmaps:" \
+ -e "/^desktopdir/s:=.*:=/usr/share/applications:" \
+ data/Makefile.am || die
+ sed -i \
+ -e '/Encoding/d' \
+ -e '/Icon/s/.svg//' \
+ data/amoebax.desktop || die
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_install() {
+ default
+ prepgamesdirs
+}
diff --git a/games-puzzle/amoebax/files/amoebax-0.2.1-aclocal.patch b/games-puzzle/amoebax/files/amoebax-0.2.1-aclocal.patch
new file mode 100644
index 000000000000..4cafc8d44de8
--- /dev/null
+++ b/games-puzzle/amoebax/files/amoebax-0.2.1-aclocal.patch
@@ -0,0 +1,41 @@
+--- m4/objc.m4.old
++++ m4/objc.m4
+@@ -448,32 +448,32 @@
+
+ # AC_LANG_SOURCE(Objective C)(BODY)
+ # ---------------------------------
+-m4_copy([AC_LANG_SOURCE(C)], [AC_LANG_SOURCE(Objective C)])
++m4_copy_force([AC_LANG_SOURCE(C)], [AC_LANG_SOURCE(Objective C)])
+
+
+ # AC_LANG_PROGRAM(Objective C)([PROLOGUE], [BODY])
+ # ------------------------------------------------
+-m4_copy([AC_LANG_PROGRAM(C)], [AC_LANG_PROGRAM(Objective C)])
++m4_copy_force([AC_LANG_PROGRAM(C)], [AC_LANG_PROGRAM(Objective C)])
+
+
+ # AC_LANG_CALL(Objective C)(PROLOGUE, FUNCTION)
+ # ---------------------------------------------
+-m4_copy([AC_LANG_CALL(C)], [AC_LANG_CALL(Objective C)])
++m4_copy_force([AC_LANG_CALL(C)], [AC_LANG_CALL(Objective C)])
+
+
+ # AC_LANG_FUNC_LINK_TRY(Objective C)(FUNCTION)
+ # --------------------------------------------
+-m4_copy([AC_LANG_FUNC_LINK_TRY(C)], [AC_LANG_FUNC_LINK_TRY(Objective C)])
++m4_copy_force([AC_LANG_FUNC_LINK_TRY(C)], [AC_LANG_FUNC_LINK_TRY(Objective C)])
+
+
+ # AC_LANG_BOOL_COMPILE_TRY(Objective C)(PROLOGUE, EXPRESSION)
+ # -----------------------------------------------------------
+-m4_copy([AC_LANG_BOOL_COMPILE_TRY(C)], [AC_LANG_BOOL_COMPILE_TRY(Objective C)])
++m4_copy_force([AC_LANG_BOOL_COMPILE_TRY(C)], [AC_LANG_BOOL_COMPILE_TRY(Objective C)])
+
+
+ # AC_LANG_INT_SAVE(Objective C)(PROLOGUE, EXPRESSION)
+ # ---------------------------------------------------
+-m4_copy([AC_LANG_INT_SAVE(C)], [AC_LANG_INT_SAVE(Objective C)])
++m4_copy_force([AC_LANG_INT_SAVE(C)], [AC_LANG_INT_SAVE(Objective C)])
+
+
+
diff --git a/games-puzzle/amoebax/files/amoebax-0.2.1-compile.patch b/games-puzzle/amoebax/files/amoebax-0.2.1-compile.patch
new file mode 100644
index 000000000000..79c66a8c95b8
--- /dev/null
+++ b/games-puzzle/amoebax/files/amoebax-0.2.1-compile.patch
@@ -0,0 +1,12 @@
+--- src/binreloc.cxx
++++ src/binreloc.cxx
+@@ -739,7 +739,8 @@
+ char *
+ br_dirname (const char *path)
+ {
+- char *end, *result;
++ const char *end;
++ char *result;
+
+ if (path == (const char *) NULL)
+ return (char *) NULL;
diff --git a/games-puzzle/amoebax/metadata.xml b/games-puzzle/amoebax/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/amoebax/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>