summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/gnurobbo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/gnurobbo')
-rw-r--r--games-puzzle/gnurobbo/Manifest1
-rw-r--r--games-puzzle/gnurobbo/files/gnurobbo-0.66-underlink.patch18
-rw-r--r--games-puzzle/gnurobbo/gnurobbo-0.66.ebuild40
-rw-r--r--games-puzzle/gnurobbo/metadata.xml8
4 files changed, 67 insertions, 0 deletions
diff --git a/games-puzzle/gnurobbo/Manifest b/games-puzzle/gnurobbo/Manifest
new file mode 100644
index 000000000000..e6c9ef4598e4
--- /dev/null
+++ b/games-puzzle/gnurobbo/Manifest
@@ -0,0 +1 @@
+DIST gnurobbo-0.66-source.tar.gz 1765034 SHA256 54d2418f49e52b8f49631eb93af7789074b628d308a6d26b00cc795ad0b04d89 SHA512 5f217ba87e8d1c56d9630cca44bde8d405c93929ebb1722c80955fceedec93a5e02ab3dbafd557c3cbedd63a97a73abe6e8aeff115931844a11f6cc1dd00533c WHIRLPOOL f51fd6d27b73dea701d7f3e1b520012f7dafbb40003550c67e34e6c6c46ecf7e910bfb1648b86c9d471d908168a97dded4b042f76f046484eb0d685a651c4e28
diff --git a/games-puzzle/gnurobbo/files/gnurobbo-0.66-underlink.patch b/games-puzzle/gnurobbo/files/gnurobbo-0.66-underlink.patch
new file mode 100644
index 000000000000..9034a6fac0e2
--- /dev/null
+++ b/games-puzzle/gnurobbo/files/gnurobbo-0.66-underlink.patch
@@ -0,0 +1,18 @@
+--- Makefile.old 2011-06-20 21:19:49.578922392 +0200
++++ Makefile 2011-06-20 21:20:28.535421648 +0200
+@@ -39,14 +39,13 @@
+ CFLAGS?=-O3 -pipe
+ CFLAGS+=-Wall `$(SDL_CONFIG) --cflags` -DPLATFORM_PC -DVERSION=\"$(VERSION)\" \
+ -DPACKAGE_DATA_DIR=\"$(PACKAGE_DATA_DIR)\" $(FONT_USE_PIXMAP) $(MUSIC) $(DESIGNER)
+-LDFLAGS=
+ # Use these instead for debugging and/or profiling (mainly intended for GNU Robbo developers)
+ #CFLAGS?=-O0 -pipe -g -pg
+ #CFLAGS+=-Wall `$(SDL_CONFIG) --cflags` -DPLATFORM_PC -DVERSION=\"$(VERSION)\" \
+ # -DPACKAGE_DATA_DIR=\"$(PACKAGE_DATA_DIR)\" $(FONT_USE_PIXMAP) $(MUSIC) $(DESIGNER)
+ #LDFLAGS=-pg
+ LINK=$(CC)
+-LIBS=`$(SDL_CONFIG) --libs` -lSDL_image -lSDL_mixer $(FONT_USE_SDL_TTF)
++LIBS=`$(SDL_CONFIG) --libs` -lSDL_image -lSDL_mixer $(FONT_USE_SDL_TTF) -lm
+
+ # You won't need to alter anything below
+ all: $(SOURCES) $(TARGET)
diff --git a/games-puzzle/gnurobbo/gnurobbo-0.66.ebuild b/games-puzzle/gnurobbo/gnurobbo-0.66.ebuild
new file mode 100644
index 000000000000..d7b890ed9c1f
--- /dev/null
+++ b/games-puzzle/gnurobbo/gnurobbo-0.66.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Robbo, a popular Atari XE/XL game ported to Linux"
+HOMEPAGE="http://gnurobbo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gnurobbo/${P}-source.tar.gz"
+
+LICENSE="GPL-2 BitstreamVera"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video,joystick]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-underlink.patch )
+
+src_compile() {
+ emake \
+ PACKAGE_DATA_DIR="${GAMES_DATADIR}/${PN}" \
+ BINDIR="${GAMES_BINDIR}" \
+ DOCDIR="/usr/share/doc/${PF}"
+}
+
+src_install() {
+ dogamesbin gnurobbo
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data/{levels,skins,locales,rob,sounds}
+ dodoc AUTHORS Bugs ChangeLog README TODO
+ newicon icon32.png ${PN}.png
+ make_desktop_entry ${PN} Gnurobbo
+ prepgamesdirs
+}
diff --git a/games-puzzle/gnurobbo/metadata.xml b/games-puzzle/gnurobbo/metadata.xml
new file mode 100644
index 000000000000..979d97db6292
--- /dev/null
+++ b/games-puzzle/gnurobbo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">gnurobbo</remote-id>
+ </upstream>
+</pkgmetadata>