summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/greedy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/greedy')
-rw-r--r--games-puzzle/greedy/Manifest1
-rw-r--r--games-puzzle/greedy/greedy-0.2.0-r1.ebuild41
-rw-r--r--games-puzzle/greedy/metadata.xml5
3 files changed, 47 insertions, 0 deletions
diff --git a/games-puzzle/greedy/Manifest b/games-puzzle/greedy/Manifest
new file mode 100644
index 000000000000..52c11c6848ae
--- /dev/null
+++ b/games-puzzle/greedy/Manifest
@@ -0,0 +1 @@
+DIST greedy-0.2.0.tar.gz 13152 SHA256 31929c41e6871698fbe2d259419fe2f31e8d4530568ccbc45a03783de970f321 SHA512 07376d003193244d336909f6336d68c4ce0f1e15388f28cc8e50121856b1f341f46f2aeba6e09118063b27d572916b4f596b75354543df3a72930a44b6b6f8ac WHIRLPOOL 68cf565dd509f37ba3a8f07c00e03813a8f3fa575a88f70a6e6d97777acfcae8cd4f7cdc6d965bfc35d9871e3d8893d519afdc0203f8914518552c467362ef3f
diff --git a/games-puzzle/greedy/greedy-0.2.0-r1.ebuild b/games-puzzle/greedy/greedy-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..3b4a9f1652c3
--- /dev/null
+++ b/games-puzzle/greedy/greedy-0.2.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs games
+
+DESCRIPTION="fun little ncurses puzzle game"
+HOMEPAGE="http://www.kotinet.com/juhamattin/linux/index.html"
+SRC_URI="http://www.kotinet.com/juhamattin/linux/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ rm -f Makefile
+ # It wants a scores file. We need to touch one and install it.
+ touch greedy.scores
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS="$($(tc-getPKG_CONFIG) ncurses --libs)" ${PN}
+}
+
+src_install() {
+ insinto "${GAMES_STATEDIR}"
+ doins greedy.scores
+
+ dogamesbin greedy
+ dodoc CHANGES README TODO
+
+ prepgamesdirs
+ # We need to set the permissions correctly
+ fperms 664 "${GAMES_STATEDIR}/greedy.scores"
+}
diff --git a/games-puzzle/greedy/metadata.xml b/games-puzzle/greedy/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/greedy/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>