summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/hangman
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/hangman')
-rw-r--r--games-puzzle/hangman/Manifest1
-rw-r--r--games-puzzle/hangman/hangman-0.9.2.ebuild37
-rw-r--r--games-puzzle/hangman/metadata.xml5
3 files changed, 43 insertions, 0 deletions
diff --git a/games-puzzle/hangman/Manifest b/games-puzzle/hangman/Manifest
new file mode 100644
index 000000000000..7b25c31cf922
--- /dev/null
+++ b/games-puzzle/hangman/Manifest
@@ -0,0 +1 @@
+DIST hangman-0.9.2.tar.gz 1023712 SHA256 5fa60699112895848b390b98f84ebb3dc4abaca431fd5c0cb25bf4d09824da2d SHA512 cbf940310b4821cf4de27a99a5228bccf42093a65ca83b0a2582556865ee5cea5a4ee2ebe08d2e02ac93f0cfc8d190b1f5427adbd74e7ddb57b90cee84f85d65 WHIRLPOOL 4e32b02a85fc0d93dc514818e6832ec4a6101a45e18b10875d97ab477ee5dd166d8d143c555e890266bde95dee53d0dd067a35a1fc577014aa52be0b1ae86670
diff --git a/games-puzzle/hangman/hangman-0.9.2.ebuild b/games-puzzle/hangman/hangman-0.9.2.ebuild
new file mode 100644
index 000000000000..0405fea9fe70
--- /dev/null
+++ b/games-puzzle/hangman/hangman-0.9.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="The classic word guessing game"
+HOMEPAGE="http://www.shiftygames.com/hangman/hangman.html"
+SRC_URI="http://www.shiftygames.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE=""
+
+DEPEND="!games-misc/bsd-games
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-ttf"
+RDEPEND="${DEPEND}
+ sys-apps/miscfiles"
+
+src_prepare() {
+ sed -i \
+ -e 's/inline void SE_CheckEvents/void SE_CheckEvents/' \
+ src/hangman.c \
+ || die "sed failed"
+}
+
+src_install() {
+ default
+ newicon pics/noose.png ${PN}.png
+ make_desktop_entry ${PN} Hangman
+ prepgamesdirs
+}
diff --git a/games-puzzle/hangman/metadata.xml b/games-puzzle/hangman/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/hangman/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>