summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/lpairs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/lpairs')
-rw-r--r--games-puzzle/lpairs/Manifest1
-rw-r--r--games-puzzle/lpairs/lpairs-1.0.4.ebuild41
-rw-r--r--games-puzzle/lpairs/metadata.xml8
3 files changed, 50 insertions, 0 deletions
diff --git a/games-puzzle/lpairs/Manifest b/games-puzzle/lpairs/Manifest
new file mode 100644
index 000000000000..f4b7424fc6c4
--- /dev/null
+++ b/games-puzzle/lpairs/Manifest
@@ -0,0 +1 @@
+DIST lpairs-1.0.4.tar.gz 536625 SHA256 350237a51a5de6b2a557af687b4f16678056a0e8d8d96d7e395f6629481462c5 SHA512 637f9782c1c1faee3fe0d02adeeb7ea70704f1b625922e1ba086cd03e9a6cf1d61a082eff4753a2ec8be5fc7041bd029f193adf847a39e773e4eedd9eafb2b97 WHIRLPOOL 36d57eb4100a03fdd73e770759330799a55973860b7213f8b4f1847d546e54197071dc064171c9f15c936d71c83b35aa9ae49c5b68ad019741d8964be1735a47
diff --git a/games-puzzle/lpairs/lpairs-1.0.4.ebuild b/games-puzzle/lpairs/lpairs-1.0.4.ebuild
new file mode 100644
index 000000000000..6d08273de8df
--- /dev/null
+++ b/games-puzzle/lpairs/lpairs-1.0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A classical memory game"
+HOMEPAGE="http://lgames.sourceforge.net/index.php?project=LPairs"
+SRC_URI="mirror://sourceforge/lgames/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls"
+
+RDEPEND="media-libs/libsdl
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i \
+ -e 's:$localedir:/usr/share/locale:' \
+ -e 's:$(localedir):/usr/share/locale:' \
+ configure po/Makefile.in.in \
+ || die "sed failed"
+}
+
+src_configure() {
+ egamesconf \
+ --datadir="${GAMES_DATADIR_BASE}" \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ doicon lpairs.png
+ make_desktop_entry lpairs LPairs
+ prepgamesdirs
+}
diff --git a/games-puzzle/lpairs/metadata.xml b/games-puzzle/lpairs/metadata.xml
new file mode 100644
index 000000000000..0f9429dd0de0
--- /dev/null
+++ b/games-puzzle/lpairs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">lgames</remote-id>
+ </upstream>
+</pkgmetadata>