summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-07-16 19:33:57 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-07-17 03:58:47 -0400
commit4cd9668d2edded13bd33aef9d9a15c46385b9ed2 (patch)
tree728d88a44232fc2397ac9e92b960b78827881c76 /games-puzzle/numptyphysics/files
parentgames-puzzle/nightsky: EAPI 7->8, hopefully fix install (diff)
downloadgentoo-4cd9668d2edded13bd33aef9d9a15c46385b9ed2.tar.gz
gentoo-4cd9668d2edded13bd33aef9d9a15c46385b9ed2.tar.bz2
gentoo-4cd9668d2edded13bd33aef9d9a15c46385b9ed2.zip
games-puzzle/numptyphysics: add 0.3.8
ebuild fixes: * -user-levels was broken due to main SRC_URI being behind user-levels? * +user-levels was pointless due to main tarball already including them in the required new format -- and downloaded levels weren't being installed either way * tc-export AR RANLIB also needed, and new patch adds PKG_CONFIG * fix icon cache (gnome2_icon_cache_update called in EAPI-7) Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-puzzle/numptyphysics/files')
-rw-r--r--games-puzzle/numptyphysics/files/numptyphysics-0.3.8-empty-tr.patch10
-rw-r--r--games-puzzle/numptyphysics/files/numptyphysics-0.3.8-respect-flags.patch30
2 files changed, 40 insertions, 0 deletions
diff --git a/games-puzzle/numptyphysics/files/numptyphysics-0.3.8-empty-tr.patch b/games-puzzle/numptyphysics/files/numptyphysics-0.3.8-empty-tr.patch
new file mode 100644
index 000000000000..847092190d35
--- /dev/null
+++ b/games-puzzle/numptyphysics/files/numptyphysics-0.3.8-empty-tr.patch
@@ -0,0 +1,10 @@
+On unrecognized LC_MESSAGES (e.g. C.utf8) the .empty() check
+fails and loads empty translations leading to constant:
+[ 1536ms] [I18n.cpp:34 WARNING] Untranslated: 'Gameplay paused'
+--- a/src/Os.cpp
++++ b/src/Os.cpp
+@@ -279,3 +279,3 @@
+ auto fn = thp::format("i18n/%s", lang);
+- if (!Config::readFile(fn).empty()) {
++ if (!access(Config::findFile(fn).c_str(),F_OK)) {
+ Tr::load(fn);
diff --git a/games-puzzle/numptyphysics/files/numptyphysics-0.3.8-respect-flags.patch b/games-puzzle/numptyphysics/files/numptyphysics-0.3.8-respect-flags.patch
new file mode 100644
index 000000000000..09b54e6ac739
--- /dev/null
+++ b/games-puzzle/numptyphysics/files/numptyphysics-0.3.8-respect-flags.patch
@@ -0,0 +1,30 @@
+diff '--color=auto' -NarU 2 a/external/Box2D/Source/Makefile b/external/Box2D/Source/Makefile
+--- a/external/Box2D/Source/Makefile 2021-06-18 07:19:06.000000000 -0400
++++ b/external/Box2D/Source/Makefile 2021-07-16 17:01:57.254825075 -0400
+@@ -7,5 +7,5 @@
+ endif
+
+-CXXFLAGS= -g -O2
++CXXFLAGS ?= -g -O2
+
+ SOURCES = \
+diff '--color=auto' -NarU 2 a/makefile b/makefile
+--- a/makefile 2021-06-18 07:19:06.000000000 -0400
++++ b/makefile 2021-07-16 17:00:51.421009113 -0400
+@@ -38,5 +38,5 @@
+ $(TARGET): $(OBJECTS) $(LOCAL_LIBS)
+ $(SILENTMSG) "\tLD\t$@\n"
+- $(SILENTCMD) $(CXX) -o $@ $^ $(LIBS)
++ $(SILENTCMD) $(CXX) -o $@ $^ $(LDFLAGS) $(LIBS)
+
+ clean: $(ADDITIONAL_CLEAN_TARGETS)
+diff '--color=auto' -NarU 2 a/mk/pkgs.mk b/mk/pkgs.mk
+--- a/mk/pkgs.mk 2021-06-18 07:19:06.000000000 -0400
++++ b/mk/pkgs.mk 2021-07-16 17:10:28.636268435 -0400
+@@ -1,4 +1,4 @@
+ ifneq ($(PKGS),)
+-CXXFLAGS += $(shell $(CROSS_COMPILE)pkg-config --cflags $(PKGS))
+-LIBS += $(shell $(CROSS_COMPILE)pkg-config --libs $(PKGS))
++CXXFLAGS += $(shell $(PKG_CONFIG) --cflags $(PKGS))
++LIBS += $(shell $(PKG_CONFIG) --libs $(PKGS))
+ endif