summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/rezerwar
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/rezerwar')
-rw-r--r--games-puzzle/rezerwar/Manifest1
-rw-r--r--games-puzzle/rezerwar/metadata.xml5
-rw-r--r--games-puzzle/rezerwar/rezerwar-0.4.2.ebuild52
3 files changed, 58 insertions, 0 deletions
diff --git a/games-puzzle/rezerwar/Manifest b/games-puzzle/rezerwar/Manifest
new file mode 100644
index 000000000000..d4a347167fb7
--- /dev/null
+++ b/games-puzzle/rezerwar/Manifest
@@ -0,0 +1 @@
+DIST rezerwar-0.4.2.tar.gz 4332498 SHA256 a93ca501803c2fdac0fb695d9a1eeed45807307316d28d3eb8abac8849fcaf02 SHA512 0ab1b00d982a96f2fd1346ff822efc68ae0e6c14a4d190ba0e8720fb119d7750851803c1387e83b93eee9cd43e332631360a67534495c20969366c885e2297ee WHIRLPOOL ee784734ac0e63de75a2e390396aaf2601285aeaf817da94b3e38056e8d7f93c13e6e6ad436ab50c703cb3da0baf9166ccec6e5ee4722b30a5694befc473a6e0
diff --git a/games-puzzle/rezerwar/metadata.xml b/games-puzzle/rezerwar/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/rezerwar/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/rezerwar/rezerwar-0.4.2.ebuild b/games-puzzle/rezerwar/rezerwar-0.4.2.ebuild
new file mode 100644
index 000000000000..f0c0f7b5e8aa
--- /dev/null
+++ b/games-puzzle/rezerwar/rezerwar-0.4.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Puzzle game like the known tetromino and the average pipe games"
+HOMEPAGE="http://tamentis.com/projects/rezerwar/"
+SRC_URI="http://tamentis.com/projects/rezerwar/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-mixer[vorbis]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e '/check_sdl$/d' \
+ -e 's/-O2 //' \
+ configure \
+ || die 'sed failed'
+ sed -i \
+ -e '/CC.*OBJECTS/s:$(CC):$(CC) $(LDFLAGS):' \
+ mkfiles/Makefile.src \
+ || die "sed failed"
+}
+
+src_configure() {
+ SDLCONFIG=sdl-config \
+ TARGET_BIN="${GAMES_BINDIR}" \
+ TARGET_DOC=/usr/share/doc/${PF} \
+ TARGET_DATA="${GAMES_DATADIR}/${PN}" \
+ ./configure \
+ || die "configure failed"
+ sed -i \
+ -e '/TARGET_DOC/d' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ dodir "${GAMES_BINDIR}"
+ default
+ dodoc doc/{CHANGES,README,TODO}
+ make_desktop_entry rezerwar Rezerwar
+ prepgamesdirs
+}