summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 16:28:12 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:34:26 +0200
commite7084aa4adf051ae840fffdd6ab5bb44656d076e (patch)
tree73f507b78fce0ba54c523457f6e84c575e457371 /games-puzzle/tint
parentgames-puzzle/textmaze: Drop old (diff)
downloadgentoo-e7084aa4adf051ae840fffdd6ab5bb44656d076e.tar.gz
gentoo-e7084aa4adf051ae840fffdd6ab5bb44656d076e.tar.bz2
gentoo-e7084aa4adf051ae840fffdd6ab5bb44656d076e.zip
games-puzzle/tint: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-puzzle/tint')
-rw-r--r--games-puzzle/tint/tint-0.03b-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-puzzle/tint/tint-0.03b-r1.ebuild b/games-puzzle/tint/tint-0.03b-r1.ebuild
new file mode 100644
index 000000000000..4b2d9dc72843
--- /dev/null
+++ b/games-puzzle/tint/tint-0.03b-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${P/-/_}"
+DESCRIPTION="Tint Is Not Tetris, a ncurses based clone of the original Tetris(tm) game"
+HOMEPAGE="http://oasis.frogfoot.net/code/tint/"
+SRC_URI="http://oasis.frogfoot.net/code/tint/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.4-r1:0="
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-ovflfix.patch )
+
+src_compile() {
+ emake \
+ STRIP=true \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ localstatedir="/var/lib"
+}
+
+src_install() {
+ dobin tint
+ doman tint.6
+ dodoc CREDITS NOTES
+ insopts -m 0664
+ insinto /var/lib
+ doins tint.scores
+}