summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 16:43:52 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:34:40 +0200
commit4ba845203461e18d0eb362dd68cea69a9faa2e7e (patch)
tree89c0255f56fe4fad9f82d6a057d044878f920591 /games-puzzle/torrent/torrent-0.8.2-r1.ebuild
parentgames-puzzle/toppler: Drop old (diff)
downloadgentoo-4ba845203461e18d0eb362dd68cea69a9faa2e7e.tar.gz
gentoo-4ba845203461e18d0eb362dd68cea69a9faa2e7e.tar.bz2
gentoo-4ba845203461e18d0eb362dd68cea69a9faa2e7e.zip
games-puzzle/torrent: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-puzzle/torrent/torrent-0.8.2-r1.ebuild')
-rw-r--r--games-puzzle/torrent/torrent-0.8.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-puzzle/torrent/torrent-0.8.2-r1.ebuild b/games-puzzle/torrent/torrent-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..76d28a5eee3a
--- /dev/null
+++ b/games-puzzle/torrent/torrent-0.8.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Match rising tiles before reaching the top to score as many points as possible"
+HOMEPAGE="http://www.shiftygames.com/torrent/torrent.html"
+SRC_URI="http://www.shiftygames.com/torrent/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=media-libs/libsdl-1.2.4
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-image-1.2
+ media-libs/sdl-ttf
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's/inline void SE_CheckEvents/void SE_CheckEvents/' \
+ src/torrent.c \
+ || die "sed failed"
+}
+
+src_install() {
+ default
+ newicon pics/sg_icon.png ${PN}.png
+ make_desktop_entry ${PN} Torrent ${PN}
+}