summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-24 09:25:37 +0000
committerSam James <sam@gentoo.org>2021-10-24 09:26:15 +0000
commit5433add0647cb10a2f7ef602ba582d07497ce285 (patch)
tree83a7f1dd7d7e16dba13c6db47b142e5ab83f8edc /games-puzzle
parentdev-ruby/tidy-ext: EAPI 8; fix extension install (diff)
downloadgentoo-5433add0647cb10a2f7ef602ba582d07497ce285.tar.gz
gentoo-5433add0647cb10a2f7ef602ba582d07497ce285.tar.bz2
gentoo-5433add0647cb10a2f7ef602ba582d07497ce285.zip
games-puzzle/toppler: EAPI 8, fix joystick dep, docdir, gamestat group
- Install to correct docdir (${PF}) - Depend on libsdl[joystick] - Use the gamestat group, not games (long gone) Closes: https://bugs.gentoo.org/818619 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/toppler/files/toppler-1.1.6-fix-docdir.patch20
-rw-r--r--games-puzzle/toppler/files/toppler-1.1.6-use-gamestat-group.patch16
-rw-r--r--games-puzzle/toppler/toppler-1.1.6-r1.ebuild28
-rw-r--r--games-puzzle/toppler/toppler-1.1.6-r2.ebuild39
4 files changed, 75 insertions, 28 deletions
diff --git a/games-puzzle/toppler/files/toppler-1.1.6-fix-docdir.patch b/games-puzzle/toppler/files/toppler-1.1.6-fix-docdir.patch
new file mode 100644
index 000000000000..410e43dec30d
--- /dev/null
+++ b/games-puzzle/toppler/files/toppler-1.1.6-fix-docdir.patch
@@ -0,0 +1,20 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -33,16 +33,14 @@ toppler_SOURCES = \
+ txtsys.cc txtsys.h \
+ qnxicon.c
+
+-docdir = $(datadir)/doc
+ pixmapsdir = $(datadir)/pixmaps
+ applicationsdir = $(datadir)/applications
+-pkgdocdir = $(docdir)/$(PACKAGE)
+ pkglocalstatedir = $(localstatedir)/$(PACKAGE)
+
+ dist_pixmaps_DATA = $(PACKAGE).xpm
+ applications_DATA = $(PACKAGE).desktop
+ dist_man_MANS = toppler.6
+-dist_pkgdoc_DATA = AUTHORS COPYING ChangeLog NEWS README
++dist_doc_DATA = AUTHORS COPYING ChangeLog NEWS README
+ dist_pkgdata_DATA = \
+ toppler.dat toppler.ogg
+
diff --git a/games-puzzle/toppler/files/toppler-1.1.6-use-gamestat-group.patch b/games-puzzle/toppler/files/toppler-1.1.6-use-gamestat-group.patch
new file mode 100644
index 000000000000..9de870deafcc
--- /dev/null
+++ b/games-puzzle/toppler/files/toppler-1.1.6-use-gamestat-group.patch
@@ -0,0 +1,16 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -55,11 +55,11 @@ EXTRA_DIST = \
+ toppler.qpg
+
+ install-exec-hook:
+- -chgrp games $(DESTDIR)$(bindir)/toppler
++ -chgrp gamestat $(DESTDIR)$(bindir)/toppler
+ -chmod 2755 $(DESTDIR)$(bindir)/toppler
+
+ install-data-hook:
+- -chgrp games $(DESTDIR)$(pkglocalstatedir)/$(PACKAGE).hsc
++ -chgrp gamestat $(DESTDIR)$(pkglocalstatedir)/$(PACKAGE).hsc
+ -chmod 0664 $(DESTDIR)$(pkglocalstatedir)/$(PACKAGE).hsc
+
+ abs_builddir = @abs_builddir@
diff --git a/games-puzzle/toppler/toppler-1.1.6-r1.ebuild b/games-puzzle/toppler/toppler-1.1.6-r1.ebuild
deleted file mode 100644
index 98307d76c751..000000000000
--- a/games-puzzle/toppler/toppler-1.1.6-r1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Reimplementation of Nebulous using SDL"
-HOMEPAGE="http://toppler.sourceforge.net/"
-SRC_URI="mirror://sourceforge/toppler/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="nls"
-
-RDEPEND="
- media-libs/libsdl[video]
- media-libs/sdl-mixer[vorbis]
- nls? ( virtual/libintl )
-"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
-"
-
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
-
-src_configure() {
- econf $(use_enable nls)
-}
diff --git a/games-puzzle/toppler/toppler-1.1.6-r2.ebuild b/games-puzzle/toppler/toppler-1.1.6-r2.ebuild
new file mode 100644
index 000000000000..08ec6d310bb3
--- /dev/null
+++ b/games-puzzle/toppler/toppler-1.1.6-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Reimplementation of Nebulous using SDL"
+HOMEPAGE="http://toppler.sourceforge.net/"
+SRC_URI="mirror://sourceforge/toppler/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="acct-group/gamestat
+ media-libs/libsdl[joystick,video]
+ media-libs/sdl-mixer[vorbis]
+ sys-libs/zlib
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-fix-docdir.patch
+ "${FILESDIR}"/${P}-use-gamestat-group.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}