summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-04-29 15:44:07 +0200
committerPacho Ramos <pacho@gentoo.org>2023-04-29 15:44:07 +0200
commit99bee84b101e6d42fb4f76019421edf344c315c6 (patch)
treec27a147b66c8d123537fb2cad794d7ba1e19223e /games-puzzle
parentapp-emacs/use-package: Keyword 2.4.5 hppa, #905201 (diff)
downloadgentoo-99bee84b101e6d42fb4f76019421edf344c315c6.tar.gz
gentoo-99bee84b101e6d42fb4f76019421edf344c315c6.tar.bz2
gentoo-99bee84b101e6d42fb4f76019421edf344c315c6.zip
games-puzzle/pingus: Fix AR detection
Thanks-to: Ionen Wolkens Thanks-to: Agostino Sarubbo Closes: https://bugs.gentoo.org/905269 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/pingus/files/pingus-0.7.6-ar-detection.patch10
-rw-r--r--games-puzzle/pingus/pingus-0.7.6-r5.ebuild1
2 files changed, 11 insertions, 0 deletions
diff --git a/games-puzzle/pingus/files/pingus-0.7.6-ar-detection.patch b/games-puzzle/pingus/files/pingus-0.7.6-ar-detection.patch
new file mode 100644
index 000000000000..839138f317eb
--- /dev/null
+++ b/games-puzzle/pingus/files/pingus-0.7.6-ar-detection.patch
@@ -0,0 +1,10 @@
+--- a/SConscript.old 2023-04-29 15:35:01.161090820 +0200
++++ b/SConscript 2023-04-29 15:36:38.909311880 +0200
+@@ -88,6 +88,7 @@
+ self.opts.Add('BUILD', 'Set the build type', "default")
+ self.opts.Add('CC', 'C Compiler', 'gcc')
+ self.opts.Add('CXX', 'C++ Compiler', 'g++')
++ self.opts.Add('AR', 'Archiver', 'ar')
+ # self.opts.Add('debug', 'Build with debugging options', 0)
+ # self.opts.Add('profile', 'Build with profiling support', 0)
+
diff --git a/games-puzzle/pingus/pingus-0.7.6-r5.ebuild b/games-puzzle/pingus/pingus-0.7.6-r5.ebuild
index b9cf5c7b0a22..11f6cb1c5cb1 100644
--- a/games-puzzle/pingus/pingus-0.7.6-r5.ebuild
+++ b/games-puzzle/pingus/pingus-0.7.6-r5.ebuild
@@ -35,6 +35,7 @@ PATCHES=(
"${FILESDIR}"/${P}-boost_signals2.patch
"${FILESDIR}"/${P}-python3.patch
"${FILESDIR}"/${P}-gcc13.patch
+ "${FILESDIR}"/${P}-ar-detection.patch
)
src_compile() {