summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-10-04 07:14:18 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-10-04 12:52:41 -0400
commitc922d6c4e438afa4681c3999301035b78c736455 (patch)
treefd1ceaa51a943780311c925f0599280e11e5f895 /games-puzzle
parentgames-puzzle/gemdropx: remove old (diff)
downloadgentoo-c922d6c4e438afa4681c3999301035b78c736455.tar.gz
gentoo-c922d6c4e438afa4681c3999301035b78c736455.tar.bz2
gentoo-c922d6c4e438afa4681c3999301035b78c736455.zip
games-puzzle/concentration: EAPI8, minor improvements
Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/657602 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/concentration/concentration-1.2-r3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-puzzle/concentration/concentration-1.2-r3.ebuild b/games-puzzle/concentration/concentration-1.2-r3.ebuild
new file mode 100644
index 000000000000..eb664032ce85
--- /dev/null
+++ b/games-puzzle/concentration/concentration-1.2-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DESCRIPTION="The classic memory game with some new life"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-ttf"
+RDEPEND="${DEPEND}
+ !sci-biology/unafold"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_install() {
+ default
+
+ newicon pics/set1/19.png ${PN}.png
+ make_desktop_entry ${PN} ${PN^}
+}