summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 16:33:39 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:34:30 +0200
commitebf5c2a868447fdb1e534fd74e4add8ee0baf4e2 (patch)
treeaac4902f7191f5e5e8bd6abda1224f8f6d880101 /games-puzzle
parentgames-puzzle/tint: Drop old (diff)
downloadgentoo-ebf5c2a868447fdb1e534fd74e4add8ee0baf4e2.tar.gz
gentoo-ebf5c2a868447fdb1e534fd74e4add8ee0baf4e2.tar.bz2
gentoo-ebf5c2a868447fdb1e534fd74e4add8ee0baf4e2.zip
games-puzzle/tod: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/tod/files/tod-0-makefile.patch4
-rw-r--r--games-puzzle/tod/tod-0-r1.ebuild37
2 files changed, 39 insertions, 2 deletions
diff --git a/games-puzzle/tod/files/tod-0-makefile.patch b/games-puzzle/tod/files/tod-0-makefile.patch
index cd17d1cce42b..9783fab0c4bc 100644
--- a/games-puzzle/tod/files/tod-0-makefile.patch
+++ b/games-puzzle/tod/files/tod-0-makefile.patch
@@ -1,5 +1,5 @@
---- makefile
-+++ makefile
+--- a/makefile
++++ b/makefile
@@ -1,8 +1,7 @@
OBJ = hiscore rec scrctl tetanus crc allegdlg hgrcos
HEADS = tod.h allegdlg.h crc.h hgrcos.h hiscore.h
diff --git a/games-puzzle/tod/tod-0-r1.ebuild b/games-puzzle/tod/tod-0-r1.ebuild
new file mode 100644
index 000000000000..0ed9a29063f0
--- /dev/null
+++ b/games-puzzle/tod/tod-0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Tetanus On Drugs simulates playing Tetris under the influence of drugs"
+HOMEPAGE="http://www.pineight.com/tod/"
+SRC_URI="http://www.pineight.com/pc/win${PN}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/allegro:0[X]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${P}-makefile.patch
+ sed -i \
+ -e "s:idltd\.dat:/usr/share/${PN}/idltd.dat:" \
+ rec.c || die
+}
+
+src_install() {
+ newbin tod-debug.exe tod
+ insinto /usr/share/${PN}
+ doins idltd.dat
+ dodoc readme.txt
+ make_desktop_entry ${PN} "Tetanus On Drugs"
+}