summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-06-15 00:05:16 +0100
committerJames Le Cuirot <chewi@gentoo.org>2018-06-15 00:07:47 +0100
commite1f9a0297c0b74d4ca648d26fbac75c3823352e8 (patch)
tree85cdfd509cf5f33ab942b378f8b0d275f5dfaff7 /games-rpg/avadon
parentpackage.mask: games-action/trine2 has been spared from last-rites (diff)
downloadgentoo-e1f9a0297c0b74d4ca648d26fbac75c3823352e8.tar.gz
gentoo-e1f9a0297c0b74d4ca648d26fbac75c3823352e8.tar.bz2
gentoo-e1f9a0297c0b74d4ca648d26fbac75c3823352e8.zip
games-rpg/avadon: Version bump, drop games eclass
Not sure if this version is actually any different as it just says 1.0 in the game. The long number in the filename is a timestamp. The Humble Bundle download had changed though so this needed updating to save it from last-rites. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'games-rpg/avadon')
-rw-r--r--games-rpg/avadon/Manifest2
-rw-r--r--games-rpg/avadon/avadon-1.0.4.ebuild55
-rw-r--r--games-rpg/avadon/avadon-1.0.4_p1331768904.ebuild53
3 files changed, 54 insertions, 56 deletions
diff --git a/games-rpg/avadon/Manifest b/games-rpg/avadon/Manifest
index dc8d0b5c6ffa..0f0df9a49eb2 100644
--- a/games-rpg/avadon/Manifest
+++ b/games-rpg/avadon/Manifest
@@ -1 +1 @@
-DIST avadon-black-fortress_1.0.4_all.run 109767395 SHA256 1619401aa42abe055b3eabf8b63d4ada3ce55affb054d0d6a6da09affe1c76fe SHA512 7c1acbb1ce3bbfb33052454c9b93060fa97b13fbf4202ee2bb0d70fb59423efc05dfe0bca07cce1e711af9f2757b79c590f237dea5f92aa11aa5979c35d018a7 WHIRLPOOL 751b5ce976a0dcb23065786d5078a32468c0f9a7a1df8eac6884923ad244996c43b7ad25044ee5fd7f680bcaa78982add53b9e248c5794f1c647309c5dbf2afc
+DIST avadon-linux-1331768904-bin.txt 109767395 BLAKE2B ba89e4cc9d7374b4c140f36860bb3e2682bc8639503500d0371a7783c0ce7fc1b40ac2c552285f03d564ecae21d5f887f822e6785a30034fdeaba9d0837ee6eb SHA512 7c1acbb1ce3bbfb33052454c9b93060fa97b13fbf4202ee2bb0d70fb59423efc05dfe0bca07cce1e711af9f2757b79c590f237dea5f92aa11aa5979c35d018a7
diff --git a/games-rpg/avadon/avadon-1.0.4.ebuild b/games-rpg/avadon/avadon-1.0.4.ebuild
deleted file mode 100644
index 02402a4db16b..000000000000
--- a/games-rpg/avadon/avadon-1.0.4.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils unpacker games
-
-DESCRIPTION="Epic fantasy role-playing adventure in an enormous and unique world"
-HOMEPAGE="http://www.spiderwebsoftware.com/avadon/index.html"
-SRC_URI="avadon-black-fortress_${PV}_all.run"
-
-LICENSE="all-rights-reserved"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
-RESTRICT="fetch bindist"
-
-QA_PREBUILT="${GAMES_PREFIX_OPT#/}/${PN}/Avadon*"
-
-RDEPEND="media-libs/libsdl[X,opengl,video]
- media-libs/openal"
-DEPEND="app-arch/unzip"
-
-S=${WORKDIR}/data
-
-pkg_nofetch() {
- einfo
- einfo "Please buy & download \"${SRC_URI}\" from:"
- einfo " ${HOMEPAGE}"
- einfo "and move/link it to \"${DISTDIR}\""
- einfo
-}
-
-src_unpack() {
- unpack_zip ${A}
-}
-
-src_install() {
- local dir=${GAMES_PREFIX_OPT}/${PN}
- local arch=$(usex amd64 "amd64" "x86")
-
- insinto "${dir}"
- doins -r "avadon files" icon.bmp
-
- exeinto "${dir}"
- doexe Avadon-${arch}
-
- newicon Avadon.png ${PN}.png
- games_make_wrapper ${PN} "./Avadon-${arch}" "${dir}"
- make_desktop_entry ${PN} "Avadon: The Black Fortress"
-
- dodoc README-linux.txt
-
- prepgamesdirs
-}
diff --git a/games-rpg/avadon/avadon-1.0.4_p1331768904.ebuild b/games-rpg/avadon/avadon-1.0.4_p1331768904.ebuild
new file mode 100644
index 000000000000..4a9ff4f3cecd
--- /dev/null
+++ b/games-rpg/avadon/avadon-1.0.4_p1331768904.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop gnome2-utils unpacker
+
+DESCRIPTION="Epic fantasy role-playing adventure in an enormous and unique world"
+HOMEPAGE="https://www.spiderwebsoftware.com/avadon"
+SRC_URI="avadon-linux-${PV#*_p}-bin.txt" # .txt is odd but that's what Humble Bundle sends.
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="fetch bindist"
+
+QA_PREBUILT="opt/${PN}/Avadon"
+
+RDEPEND="media-libs/libsdl[opengl,video]
+ media-libs/openal"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/data"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ local dir=/opt/${PN}
+
+ insinto "${dir}"
+ doins -r "avadon files" icon.bmp
+
+ exeinto "${dir}"
+ newexe Avadon-$(usex amd64 amd64 x86) Avadon
+ dosym "../..${dir}"/Avadon /usr/bin/${PN}
+
+ newicon -s 512 Avadon.png ${PN}.png
+ make_desktop_entry ${PN} "Avadon: The Black Fortress"
+
+ dodoc README-linux.txt
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }