summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-06 04:29:00 +0000
committerSam James <sam@gentoo.org>2021-11-06 04:29:00 +0000
commiteb9328fe3472b826a77241ffe6d01738cae2342e (patch)
tree12f0f8d34960a0ec5c3b356f8c80679a9ac230a8 /games-rpg/manaplus/manaplus-9999.ebuild
parentx11-libs/pango: Stabilize 1.48.10-r1 hppa, #815013 (diff)
downloadgentoo-eb9328fe3472b826a77241ffe6d01738cae2342e.tar.gz
gentoo-eb9328fe3472b826a77241ffe6d01738cae2342e.tar.bz2
gentoo-eb9328fe3472b826a77241ffe6d01738cae2342e.zip
games-rpg/manaplus: drop unnecessary/incorrect src_test
- 'make check' won't catch errors and the default src_test implementation works here for us anyway. - sync with live ebuild. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-rpg/manaplus/manaplus-9999.ebuild')
-rw-r--r--games-rpg/manaplus/manaplus-9999.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/games-rpg/manaplus/manaplus-9999.ebuild b/games-rpg/manaplus/manaplus-9999.ebuild
index 4682afacd0d7..c93acd1164d1 100644
--- a/games-rpg/manaplus/manaplus-9999.ebuild
+++ b/games-rpg/manaplus/manaplus-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -57,6 +57,7 @@ DEPEND="${RDEPEND}
src_prepare() {
default
+
if [[ ${PV} == 9999 ]] ; then
eautoreconf
fi
@@ -73,7 +74,8 @@ src_configure() {
$(use_with sdl2)
$(use_enable test unittests)
)
- CONFIG_SHELL="/bin/bash" econf "${myeconfargs[@]}"
+
+ CONFIG_SHELL="${BROOT}/bin/bash" econf "${myeconfargs[@]}"
}
src_install() {
@@ -95,7 +97,3 @@ src_install() {
dosym ${srcpath}/mplus-outline-fonts/mplus-1p-regular.ttf "${destpath}"/mplus-1p-regular.ttf
dosym ${srcpath}/wqy-microhei/wqy-microhei.ttc "${destpath}"/wqy-microhei.ttf
}
-
-src_test() {
- make check
-}