summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/valyriatear
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/valyriatear')
-rw-r--r--games-rpg/valyriatear/Manifest1
-rw-r--r--games-rpg/valyriatear/metadata.xml12
-rw-r--r--games-rpg/valyriatear/valyriatear-1.0.0.ebuild66
3 files changed, 79 insertions, 0 deletions
diff --git a/games-rpg/valyriatear/Manifest b/games-rpg/valyriatear/Manifest
new file mode 100644
index 000000000000..e21a9c781948
--- /dev/null
+++ b/games-rpg/valyriatear/Manifest
@@ -0,0 +1 @@
+DIST valyriatear-1.0.0.tar.gz 100847837 SHA256 cfb6fc1a1fb677de4c67d2092456cc453c6778905927408a97230d03cedc5a1e SHA512 5dc9b3f5dfc61b1d25271b8934f0089bec379d6060d7a7d3a13e4383262593232f87780096d4ecaf00a942c18422350370fd9c6418a3ff8b12e7839422b0ed95 WHIRLPOOL b1f7e26e6ce4297c860017439200d5b3a8333d41cff95ba1bf5c402ffdebce35e0131a053650b443d11b897dc7b00e9576a457c9750a12d53851cf1cbb2c4dc4
diff --git a/games-rpg/valyriatear/metadata.xml b/games-rpg/valyriatear/metadata.xml
new file mode 100644
index 000000000000..6a16693e688b
--- /dev/null
+++ b/games-rpg/valyriatear/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name='editor'>Compile the Qt editor along with the game</flag>
+ </use>
+ <upstream>
+ <remote-id type='github'>Bertram25/ValyriaTear</remote-id>
+ </upstream>
+</pkgmetadata>
+
diff --git a/games-rpg/valyriatear/valyriatear-1.0.0.ebuild b/games-rpg/valyriatear/valyriatear-1.0.0.ebuild
new file mode 100644
index 000000000000..3610defcd813
--- /dev/null
+++ b/games-rpg/valyriatear/valyriatear-1.0.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils games
+
+MY_P=ValyriaTear-${PV/_rc/-rc}
+
+DESCRIPTION="A free 2D J-RPG based on the Hero of Allacrost engine"
+HOMEPAGE="http://valyriatear.blogspot.de/
+ https://github.com/Bertram25/ValyriaTear"
+SRC_URI="https://github.com/Bertram25/ValyriaTear/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-2+ GPL-3 CC-BY-SA-3.0 CC-BY-3.0 CC0-1.0 OFL-1.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug editor nls"
+
+RDEPEND="
+ dev-cpp/luabind
+ dev-lang/lua
+ media-libs/libpng:0=
+ media-libs/libsdl[X,joystick,opengl,video]
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/sdl-image[png]
+ media-libs/sdl-ttf
+ virtual/glu
+ virtual/opengl
+ x11-libs/libX11
+ editor? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SYSTEM_LUABIND=ON
+ -DPKG_BINDIR="${GAMES_BINDIR}"
+ -DPKG_DATADIR="${GAMES_DATADIR}/${PN}"
+ $(cmake-utils_use editor EDITOR_SUPPORT)
+ $(cmake-utils_use !nls DISABLE_TRANSLATIONS)
+ $(cmake-utils_use debug DEBUG_FEATURES)
+ -DUSE_PCH_COMPILATION=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ prepgamesdirs
+}