summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-07-17 10:10:57 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-07-17 10:12:44 +0200
commit23e95430b79b520423d7a1524d296e3dd9beb5c9 (patch)
tree3e032384ba91cc156521d028c03d16451eb4e3bc /games-rpg
parentmedia-fonts/terminus-font: Bump to version 4.46 (diff)
downloadgentoo-23e95430b79b520423d7a1524d296e3dd9beb5c9.tar.gz
gentoo-23e95430b79b520423d7a1524d296e3dd9beb5c9.tar.bz2
gentoo-23e95430b79b520423d7a1524d296e3dd9beb5c9.zip
games-rpg/manaplus: Bump to version 1.7.7.8
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/manaplus/Manifest1
-rw-r--r--games-rpg/manaplus/manaplus-1.7.7.8.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/games-rpg/manaplus/Manifest b/games-rpg/manaplus/Manifest
index 717618542665..2161a64330bc 100644
--- a/games-rpg/manaplus/Manifest
+++ b/games-rpg/manaplus/Manifest
@@ -1,2 +1,3 @@
DIST manaplus-1.7.6.10.tar.xz 14847988 SHA256 14e20a63d33fc1a30af16e7143e3015baead9db957ea2c38a90a08fcefe6fa50 SHA512 ca8a191c37758883d593dd1f8718fe4c8f9620fac5fd6034aad12a84815ec75e725e26a868673fe25c59efef7f21012869f6f90156ca93d2d48b26c8ffdd87cf WHIRLPOOL fbee48f38ba09ec5e9125e17311d844d0a2af464a90d962f7eb3d3ed06a7e93f035f12391ff397307b7e9408002159948f37718f0bcb642e2df78521b5164ce3
DIST manaplus-1.7.6.24.tar.xz 14864072 SHA256 d5504420d2a1eb0de0459ff738257636a321fcd871dceb21ca086a2a735a0c07 SHA512 71e030854abbaa19ad6a460598d4506e9fad8ff0cfe8c26926415ebd4a203b438dc3a578cb583225fa4c36b66cf0a5d580e0dd6dfe62aedee783d4aba683b8d0 WHIRLPOOL 791df12e1846306b1ed6a619671d91ade40a82057a8d3c394aea59e85eca539a95f988c548a308474c9eecfce23079d536fb7a49d34c6ecdffac59022f100cbf
+DIST manaplus-1.7.7.8.tar.xz 14860880 SHA256 4c9473c5423076e9b7010e78dbb85d2c0aa63edcf7577fe4048adba6b6adbea5 SHA512 9316297d5d766997913a465197da336516a8c1dbb30e193a1dca6ad083aa990788a147481a09cb6bcc044fdce575222c21797cef47107123141296c354639128 WHIRLPOOL 2d550f29e7d42549c095a1bf0db398d903e59e4f054d5751fd19259fa73615567a58ff1412aa97757efde18aad64fadf0220b8ad9f8e8ca44a5cdea1f564b875
diff --git a/games-rpg/manaplus/manaplus-1.7.7.8.ebuild b/games-rpg/manaplus/manaplus-1.7.7.8.ebuild
new file mode 100644
index 000000000000..2d5897b5d6f1
--- /dev/null
+++ b/games-rpg/manaplus/manaplus-1.7.7.8.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ManaPlus/ManaPlus.git"
+else
+ SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="mumble nls opengl pugixml +sdl2 test"
+
+RDEPEND="
+ >=dev-games/physfs-1.0.0
+ media-fonts/dejavu
+ media-fonts/liberation-fonts
+ media-fonts/mplus-outline-fonts
+ media-fonts/wqy-microhei
+ media-libs/libpng:0=
+ net-misc/curl
+ sys-libs/zlib
+ x11-apps/xmessage
+ x11-libs/libX11
+ x11-misc/xdg-utils
+ mumble? ( media-sound/mumble )
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )
+ pugixml? ( dev-libs/pugixml )
+ !pugixml? ( dev-libs/libxml2 )
+ sdl2? (
+ media-libs/libsdl2[X,opengl?,video]
+ media-libs/sdl2-gfx
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-net
+ media-libs/sdl2-ttf
+ )
+ !sdl2? (
+ media-libs/libsdl[X,opengl?,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localedir=/usr/share/locale
+ --without-internalsdlgfx
+ $(use_with mumble)
+ $(use_enable nls)
+ $(use_with opengl)
+ --enable-libxml=$(usex pugixml pugixml libxml)
+ $(use_with sdl2)
+ $(use_enable test unittests)
+ )
+ CONFIG_SHELL=/bin/bash econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ local destpath="/usr/share/${PN}"
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${destpath}"/data/fonts/dejavusans-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${destpath}"/data/fonts/dejavusans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf "${destpath}"/data/fonts/dejavusansmono-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${destpath}"/data/fonts/dejavusansmono.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed-Bold.ttf "${destpath}"/data/fonts/dejavuserifcondensed-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed.ttf "${destpath}"/data/fonts/dejavuserifcondensed.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Bold.ttf "${destpath}"/data/fonts/liberationsansmono-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Regular.ttf "${destpath}"/data/fonts/liberationsansmono.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Bold.ttf "${destpath}"/data/fonts/liberationsans-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Regular.ttf "${destpath}"/data/fonts/liberationsans.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-bold.ttf "${destpath}"/data/fonts/mplus-1p-bold.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-regular.ttf "${destpath}"/data/fonts/mplus-1p-regular.ttf
+ dosym /usr/share/fonts/wqy-microhei/wqy-microhei.ttc "${destpath}"/data/fonts/wqy-microhei.ttf
+}
+
+src_test() {
+ make check
+}