summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-10-17 12:35:55 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-10-17 12:37:43 +0200
commitccf7ebdfd48259901aa7ef5ee103f3f4327a74b7 (patch)
tree58253dc3a656fcc6fc6eac3d99a95103b417aa14 /games-rpg
parentmedia-video/smplayer: Bump to version 17.0.2 (diff)
downloadgentoo-ccf7ebdfd48259901aa7ef5ee103f3f4327a74b7.tar.gz
gentoo-ccf7ebdfd48259901aa7ef5ee103f3f4327a74b7.tar.bz2
gentoo-ccf7ebdfd48259901aa7ef5ee103f3f4327a74b7.zip
games-rpg/manaplus: Bump to version 1.7.10.14
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/manaplus/Manifest1
-rw-r--r--games-rpg/manaplus/manaplus-1.7.10.14.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/games-rpg/manaplus/Manifest b/games-rpg/manaplus/Manifest
index ced3461d417c..4c658a81a37e 100644
--- a/games-rpg/manaplus/Manifest
+++ b/games-rpg/manaplus/Manifest
@@ -1,2 +1,3 @@
+DIST manaplus-1.7.10.14.tar.xz 14932496 SHA256 0a59af85953b1f73de8d1e2ff0be567167088ce8342e30537f49dc8784597f04 SHA512 9be54eeee2c0defb7affe7a01e071c152c854a9cc0a16179c967cb1980ebc3ee837004beb991fc9f603424797bf54146e04eee3221d233f448966afac4c784db WHIRLPOOL 7a311174b9c537c6964f519c6889348ccc929225d7466cfbd2a6b643155a2dbbb1cb8332ad8b9bcc7804d9dd0bf6d9b1cb1368692faa35e612f6a5a0575465be
DIST manaplus-1.7.9.2.tar.xz 14900648 SHA256 8fcbdf7cc5045e7f0118152774e6e190d27f9e612c440d929d5c02750716542d SHA512 9bb4888d85d133dbd730dfeb49456ef849bae04f9c8e4bd7b5fe1e4541ee4da291c193057e6ca77a7802b5256e977dccec334a5c6cbbcfa424f2faf2a6c2fe91 WHIRLPOOL af70949ae9b985607c2afb3432a1d0757470cf1d4ce896543d099e2b1c0d9ee5a362720cf0edc5ae5cb567a876f8acb7c19cef5fd04aa9db3f17406a1a910877
DIST manaplus-1.7.9.30.tar.xz 14930020 SHA256 1ae531f2e049a26edbb8f373348c620d2f3761cefb6a49a9a4399e0f40cd9c6a SHA512 5be99c4199de09e05472f4c835466932693f5a86f3bfc7d79426c96adfeb3f6e4e647f511ab0c9c31433e3ed481e6df5a7a83abf50784587b8b95493c1391646 WHIRLPOOL af62630410a1d276d6ff5408aaf4bce3b13c6fd3bc2a2aa09176987175cecc8d0e621dd75c27c5e176abae73ef27651fac60f841861fb17ddb899cd0954d0598
diff --git a/games-rpg/manaplus/manaplus-1.7.10.14.ebuild b/games-rpg/manaplus/manaplus-1.7.10.14.ebuild
new file mode 100644
index 000000000000..2d5897b5d6f1
--- /dev/null
+++ b/games-rpg/manaplus/manaplus-1.7.10.14.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ManaPlus/ManaPlus.git"
+else
+ SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="mumble nls opengl pugixml +sdl2 test"
+
+RDEPEND="
+ >=dev-games/physfs-1.0.0
+ media-fonts/dejavu
+ media-fonts/liberation-fonts
+ media-fonts/mplus-outline-fonts
+ media-fonts/wqy-microhei
+ media-libs/libpng:0=
+ net-misc/curl
+ sys-libs/zlib
+ x11-apps/xmessage
+ x11-libs/libX11
+ x11-misc/xdg-utils
+ mumble? ( media-sound/mumble )
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )
+ pugixml? ( dev-libs/pugixml )
+ !pugixml? ( dev-libs/libxml2 )
+ sdl2? (
+ media-libs/libsdl2[X,opengl?,video]
+ media-libs/sdl2-gfx
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-net
+ media-libs/sdl2-ttf
+ )
+ !sdl2? (
+ media-libs/libsdl[X,opengl?,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localedir=/usr/share/locale
+ --without-internalsdlgfx
+ $(use_with mumble)
+ $(use_enable nls)
+ $(use_with opengl)
+ --enable-libxml=$(usex pugixml pugixml libxml)
+ $(use_with sdl2)
+ $(use_enable test unittests)
+ )
+ CONFIG_SHELL=/bin/bash econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ local destpath="/usr/share/${PN}"
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${destpath}"/data/fonts/dejavusans-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${destpath}"/data/fonts/dejavusans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf "${destpath}"/data/fonts/dejavusansmono-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${destpath}"/data/fonts/dejavusansmono.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed-Bold.ttf "${destpath}"/data/fonts/dejavuserifcondensed-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed.ttf "${destpath}"/data/fonts/dejavuserifcondensed.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Bold.ttf "${destpath}"/data/fonts/liberationsansmono-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationMono-Regular.ttf "${destpath}"/data/fonts/liberationsansmono.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Bold.ttf "${destpath}"/data/fonts/liberationsans-bold.ttf
+ dosym /usr/share/fonts/liberation-fonts/LiberationSans-Regular.ttf "${destpath}"/data/fonts/liberationsans.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-bold.ttf "${destpath}"/data/fonts/mplus-1p-bold.ttf
+ dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-regular.ttf "${destpath}"/data/fonts/mplus-1p-regular.ttf
+ dosym /usr/share/fonts/wqy-microhei/wqy-microhei.ttc "${destpath}"/data/fonts/wqy-microhei.ttf
+}
+
+src_test() {
+ make check
+}