summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-simulation/bcs-demo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-simulation/bcs-demo')
-rw-r--r--games-simulation/bcs-demo/Manifest2
-rw-r--r--games-simulation/bcs-demo/bcs-demo-1.3.ebuild59
-rw-r--r--games-simulation/bcs-demo/metadata.xml26
3 files changed, 87 insertions, 0 deletions
diff --git a/games-simulation/bcs-demo/Manifest b/games-simulation/bcs-demo/Manifest
new file mode 100644
index 000000000000..2f083fc42cdd
--- /dev/null
+++ b/games-simulation/bcs-demo/Manifest
@@ -0,0 +1,2 @@
+DIST bcsdemo_v1_3.sh.bin 5965217 SHA256 1e23f1fd2ec95e27c56037761c25e3af1ef1f23365540434b12e8b31527dbad7 SHA512 b3916ac72d21e80a09b80a406ea18ab4365d9c1b8139eec848f2e5d697d3d5afb6f27de5dac31c6b6fd860e3b406a3eae8a28aac0e00134629dbd5906bde816d WHIRLPOOL 25d2b12b9bdf6acd6695ae78f72e7712b1c0df4b99fb54c6c4621f1005d9375d265a1451955819c0d58630568533919439000f94c3adbd51ac68f6e0c7f205af
+DIST openal-alan-hack-0.0.1.tar.gz 86168 SHA256 86e09a5d43461031094c1a09382b369c6f8e231e644dde9d98b7b35fb2e0767a SHA512 1794461cb917dcf2130977bd0ac9f09bf93cd235dd742d29e50a3e2666e6db60865bacd1927fc4607a4b308dcdf421fa2a186ad2a06eea778069ce712a89d943 WHIRLPOOL 4daec7dcabacde0494ba9b4f3cf245201d6e755fd432a8edc6a73105688a1e87ac1f33334afc546617bfb45b6560cc67e150873c982b7d2b38a79ecec203e056
diff --git a/games-simulation/bcs-demo/bcs-demo-1.3.ebuild b/games-simulation/bcs-demo/bcs-demo-1.3.ebuild
new file mode 100644
index 000000000000..6ea1cd4050c2
--- /dev/null
+++ b/games-simulation/bcs-demo/bcs-demo-1.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit unpacker games
+
+DESCRIPTION="design and build bridges and then stress test them with trains"
+HOMEPAGE="http://www.chroniclogic.com/pontifex2.htm"
+SRC_URI="ftp://ggdev-1.homelan.com/bcs/bcsdemo_v${PV/./_}.sh.bin
+ http://www.highprogrammer.com/alan/pfx2/openal-alan-hack-0.0.1.tar.gz"
+
+LICENSE="BCS"
+SLOT="0"
+KEYWORDS="-* ~amd64 x86"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND="sys-libs/glibc
+ media-libs/libsdl[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+QA_PREBUILT="${dir:1}/*"
+
+src_unpack() {
+ unpack_makeself bcsdemo_v${PV/./_}.sh.bin
+ unpack openal-alan-hack-0.0.1.tar.gz
+}
+
+src_install() {
+ dodir "${dir}" "${GAMES_BINDIR}"
+
+ tar -zxf bcsdemo.tar.gz -C "${Ddir}" || die
+ rm -f "${Ddir}"/bcs-linux-openal-fixer.sh || die
+
+ exeinto "${dir}"
+# doexe bin/Linux/x86/rungame.sh
+# exeinto ${dir}/lib
+ mv "${Ddir}"/bcs "${Ddir}"/bcs-bin
+ newexe libopenal.so.0.0.6 libopenal.so.0
+ echo '#!/bin/bash' >> "${Ddir}"/bcs
+ echo 'LD_PRELOAD="./libopenal.so.0" ./bcs-bin' >> "${Ddir}"/bcs
+ fperms 750 "${dir}"/bcs
+ games_make_wrapper bcs-demo ./bcs "${dir}" "${dir}"
+
+ insinto "${dir}"
+ doins *.cfg
+ dodoc readme*
+
+ prepgamesdirs
+}
diff --git a/games-simulation/bcs-demo/metadata.xml b/games-simulation/bcs-demo/metadata.xml
new file mode 100644
index 000000000000..fb28670977d9
--- /dev/null
+++ b/games-simulation/bcs-demo/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+Building a bridge that doesn't break is what its all about, although watching
+your bridge creation break and plunge a train into the watery depths below can be
+half the fun. In the Bridge Construction Set you design and build bridges and
+then stress test them to see how your creations hold up under pressure. If when
+test vehicles pass over your bridge they make it safely across you know you've
+succeeded. If they plummet into the river you know you need to go back to the
+drawing board.
+
+The robust physics deployed in the Bridge Construction Set let you build a wide
+variety of bridges that can span the river. The 3D graphics allow you to view
+your bridge from any angle including a first person train view - its like being
+strapped to the front of the train when your bridge is first tested (if this
+happened in real life I think we might have engineers checking all their bridges
+in a simulator).
+
+The Bridge Construction Set includes many types of bridge building levels in
+varying degrees of difficulty from simple to complex with a tutorial secition to
+get you started. A Level Editor is also included so you can create your own
+levels and trade them with others.
+</longdescription>
+</pkgmetadata>