summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-simulation/senken
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-simulation/senken')
-rw-r--r--games-simulation/senken/Manifest1
-rw-r--r--games-simulation/senken/files/senken-0.3.0-as-needed.patch24
-rw-r--r--games-simulation/senken/files/senken-0.3.0-warnings.patch31
-rw-r--r--games-simulation/senken/metadata.xml5
-rw-r--r--games-simulation/senken/senken-0.3.0.ebuild50
5 files changed, 111 insertions, 0 deletions
diff --git a/games-simulation/senken/Manifest b/games-simulation/senken/Manifest
new file mode 100644
index 000000000000..95815625a9a9
--- /dev/null
+++ b/games-simulation/senken/Manifest
@@ -0,0 +1 @@
+DIST senken-0.3.0.tar.gz 1391010 SHA256 2b0c6c0f08a9dcc1c15d2c94f7c5f494953cb83bc387749fe46c1dc6fb7cb880 SHA512 df0c15cabf667fb7b56db40baf03fcae6695aa9ec0e42a7db682ff20877a5b89ee67e7799e762b4a78cf0f3fdee7f001419091f0683df74ba1bbe6b9501f0272 WHIRLPOOL fec07f5237c6b0961611caf7e6a3398f0dc5366ff391008668179af470a3bb6069aadea6a5d938cc943a30bc83e6a63e8f006be743a181aa53dadd69ddfbe204
diff --git a/games-simulation/senken/files/senken-0.3.0-as-needed.patch b/games-simulation/senken/files/senken-0.3.0-as-needed.patch
new file mode 100644
index 000000000000..428cbc9ee4c6
--- /dev/null
+++ b/games-simulation/senken/files/senken-0.3.0-as-needed.patch
@@ -0,0 +1,24 @@
+diff -ru senken-0.3.0.orig/server/Makefile.in senken-0.3.0/server/Makefile.in
+--- senken-0.3.0.orig/server/Makefile.in 2003-11-20 02:30:15.000000000 -0500
++++ senken-0.3.0/server/Makefile.in 2014-10-30 10:58:51.202157036 -0400
+@@ -10,7 +10,7 @@
+
+ DEFS = @DEFS@
+ CPPFLAGS = -I$(srcdir)/../lib -I$(srcdir) -I$(srcdir)/.. @CPPFLAGS@
+-LIBS = ../lib/libsenken.a @LIBS@ @LIBINTL@
++LIBS = ../lib/libsenken.a @LIBS@ @LIBINTL@ -lm
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+diff -ru senken-0.3.0.orig/src/Makefile.in senken-0.3.0/src/Makefile.in
+--- senken-0.3.0.orig/src/Makefile.in 2003-11-20 02:30:16.000000000 -0500
++++ senken-0.3.0/src/Makefile.in 2014-10-30 10:59:05.154704393 -0400
+@@ -8,7 +8,7 @@
+
+ DEFS = @DEFS@
+ CPPFLAGS = -I$(srcdir)/../lib -I$(srcdir) -I$(srcdir)/.. @CPPFLAGS@ @GTK_CFLAGS@
+-LIBS = ../lib/libsenken.a @LIBS@ @GTK_LIBS@
++LIBS = ../lib/libsenken.a @LIBS@ @GTK_LIBS@ -lm
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
diff --git a/games-simulation/senken/files/senken-0.3.0-warnings.patch b/games-simulation/senken/files/senken-0.3.0-warnings.patch
new file mode 100644
index 000000000000..b15565ad0a90
--- /dev/null
+++ b/games-simulation/senken/files/senken-0.3.0-warnings.patch
@@ -0,0 +1,31 @@
+diff -ru senken-0.3.0.orig/server/protocol.c senken-0.3.0/server/protocol.c
+--- senken-0.3.0.orig/server/protocol.c 2003-11-20 02:30:15.000000000 -0500
++++ senken-0.3.0/server/protocol.c 2014-10-30 11:04:39.831848871 -0400
+@@ -294,7 +294,7 @@
+ /*
+ * If transaction active just save this for later
+ */
+- if (connection_txn_active) {
++ if (connection_txn_active(conn)) {
+ set_op_t *op = calloc(1, sizeof(set_op_t));
+ int r;
+
+diff -ru senken-0.3.0.orig/src/gtkhelp_reports.c senken-0.3.0/src/gtkhelp_reports.c
+--- senken-0.3.0.orig/src/gtkhelp_reports.c 2003-11-20 02:30:16.000000000 -0500
++++ senken-0.3.0/src/gtkhelp_reports.c 2014-10-30 11:06:43.795828908 -0400
+@@ -1,3 +1,4 @@
++#include <string.h>
+ #include <gtk/gtk.h>
+ #include <gdk/gdk.h>
+
+diff -ru senken-0.3.0.orig/src/main.c senken-0.3.0/src/main.c
+--- senken-0.3.0.orig/src/main.c 2003-11-20 02:30:16.000000000 -0500
++++ senken-0.3.0/src/main.c 2014-10-30 11:06:28.147336339 -0400
+@@ -25,6 +25,7 @@
+ # include <config.h>
+ #endif
+
++#include <string.h>
+ #include <unistd.h>
+ #include <signal.h>
+ #include <gtk/gtk.h>
diff --git a/games-simulation/senken/metadata.xml b/games-simulation/senken/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-simulation/senken/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-simulation/senken/senken-0.3.0.ebuild b/games-simulation/senken/senken-0.3.0.ebuild
new file mode 100644
index 000000000000..f393cbd9f699
--- /dev/null
+++ b/games-simulation/senken/senken-0.3.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="city simulation game"
+HOMEPAGE="http://savannah.nongnu.org/projects/senken/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="nls"
+
+RDEPEND="x11-libs/gtk+:2
+ >=media-libs/libsdl-1.2.4
+ media-libs/sdl-image
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i \
+ -e "s:/usr/local/share:${GAMES_DATADIR}:" \
+ lib/utils.h || die
+ epatch \
+ "${FILESDIR}"/${P}-as-needed.patch \
+ "${FILESDIR}"/${P}-warnings.patch
+}
+src_configure() {
+ egamesconf $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ dodir "${GAMES_DATADIR}"
+ mv "${D}/${GAMES_PREFIX}/share/senken" "${D}/${GAMES_DATADIR}/" || die
+ rm -rf "${D}/${GAMES_PREFIX}"/{include,lib,man,share} || die
+
+ insinto "${GAMES_DATADIR}/senken/img"
+ doins img/*.png
+
+ find "${D}/${GAMES_DATADIR}/" -type f -exec chmod a-x \{\} +
+ find "${D}/${GAMES_DATADIR}/" -name "Makefile.*" -exec rm -f \{\} +
+
+ prepgamesdirs
+}