summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-sports/gracer/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-sports/gracer/files')
-rw-r--r--games-sports/gracer/files/0.1.5-gldefs.patch33
-rw-r--r--games-sports/gracer/files/gracer-0.1.5-as-needed.patch11
-rw-r--r--games-sports/gracer/files/gracer-0.1.5-gcc41.patch11
-rw-r--r--games-sports/gracer/files/gracer-0.1.5-libpng14.patch13
-rw-r--r--games-sports/gracer/files/gracer-0.1.5-png15.patch11
-rw-r--r--games-sports/gracer/files/gracer-gcc-3.4.patch120
6 files changed, 199 insertions, 0 deletions
diff --git a/games-sports/gracer/files/0.1.5-gldefs.patch b/games-sports/gracer/files/0.1.5-gldefs.patch
new file mode 100644
index 000000000000..825edff861dc
--- /dev/null
+++ b/games-sports/gracer/files/0.1.5-gldefs.patch
@@ -0,0 +1,33 @@
+--- src/glbind.c.orig 2003-07-30 00:18:37.000000000 -0400
++++ src/glbind.c 2003-07-30 00:19:32.000000000 -0400
+@@ -22,6 +22,8 @@
+ #include <unistd.h>
+ #include <GL/gl.h>
+ #include <GL/glut.h>
++#undef GL_EXT_texture_object
++#include <GL/glext.h>
+ #include <string.h>
+ #include <stdlib.h>
+ #include <ctype.h>
+--- src/glhash.h.orig 2003-07-30 00:20:32.000000000 -0400
++++ src/glhash.h 2003-07-30 00:20:58.000000000 -0400
+@@ -1,4 +1,5 @@
+ /* this file is generated automaticaly from GL/gl.h */
++#undef GL_EXT_paletted_texture
+ #include <GL/gl.h>
+
+ glWordList glwordlist[] = {
+@@ -632,13 +632,11 @@
+
+ #ifdef GL_SGIS_multitexture
+ {"selected_texture_sgis", GL_SELECTED_TEXTURE_SGIS},
+- {"selected_texture_coord_set_sgis", GL_SELECTED_TEXTURE_COORD_SET_SGIS},
+ {"max_textures_sgis", GL_MAX_TEXTURES_SGIS},
+ {"texture0_sgis", GL_TEXTURE0_SGIS},
+ {"texture1_sgis", GL_TEXTURE1_SGIS},
+ {"texture2_sgis", GL_TEXTURE2_SGIS},
+ {"texture3_sgis", GL_TEXTURE3_SGIS},
+- {"texture_coord_set_source_sgis", GL_TEXTURE_COORD_SET_SOURCE_SGIS},
+ #endif
+
+ #ifdef GL_EXT_multitexture
diff --git a/games-sports/gracer/files/gracer-0.1.5-as-needed.patch b/games-sports/gracer/files/gracer-0.1.5-as-needed.patch
new file mode 100644
index 000000000000..3d3c53bcd46e
--- /dev/null
+++ b/games-sports/gracer/files/gracer-0.1.5-as-needed.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.in.old 2009-02-11 14:31:56.000000000 +0100
++++ src/Makefile.in 2009-02-11 14:32:29.000000000 +0100
+@@ -109,7 +109,7 @@
+ INCLUDES = -I$(top_srcdir) @X_CFLAGS@ @GL_CFLAGS@ @GLUT_CFLAGS@ @TCL_CFLAGS@ @GIF_CFLAGS@ @JPEG_CFLAGS@ @PNG_CFLAGS@ @PLIB_CFLAGS@
+
+
+-gracer_LDADD = @PLIB_LDFLAGS@ @GIF_LDFLAGS@ @JPEG_LDFLAGS@ @PNG_LDFLAGS@ @GL_LDFLAGS@ @GLUT_LDFLAGS@ @X_LDFLAGS@ @TCL_LDFLAGS@ @TCL_LIBS@ @X_LIBS@ @GL_LIBS@ @GLUT_LIBS@ @GIF_LIBS@ @JPEG_LIBS@ @PNG_LIBS@ @SOUND_LIBS@ $(top_builddir)/common/libcommon.a
++gracer_LDADD = $(top_builddir)/common/libcommon.a @PLIB_LDFLAGS@ @GIF_LDFLAGS@ @JPEG_LDFLAGS@ @PNG_LDFLAGS@ @GL_LDFLAGS@ @GLUT_LDFLAGS@ @X_LDFLAGS@ @TCL_LDFLAGS@ @TCL_LIBS@ @X_LIBS@ @GL_LIBS@ @GLUT_LIBS@ @GIF_LIBS@ @JPEG_LIBS@ @PNG_LIBS@ @SOUND_LIBS@
+
+
+ gracer_SOURCES = control.h glbind.c glbind.h glutwidgets.c glutwidgets.h gluttclwidgets.c gluttclwidgets.h glutgame.c glutgame.h gr_world.c gr_world.h glhash.h gluthash.h vehicle.c vehicle.h lap.c lap.h joystick.c joystick.h tcldefs.h sound.h sound.cxx main.cxx
diff --git a/games-sports/gracer/files/gracer-0.1.5-gcc41.patch b/games-sports/gracer/files/gracer-0.1.5-gcc41.patch
new file mode 100644
index 000000000000..7d47f96b98c8
--- /dev/null
+++ b/games-sports/gracer/files/gracer-0.1.5-gcc41.patch
@@ -0,0 +1,11 @@
+--- common/gr_memory.h.old 2006-05-23 09:16:21.000000000 +0200
++++ common/gr_memory.h 2006-05-23 09:16:40.000000000 +0200
+@@ -64,7 +64,7 @@
+ void gr_dlist_free (GrDList *list);
+
+ #define gr_FOREACH(l,p) \
+- for (; (l) != NULL && ((void *)(p) = (l)->data, 1); (l) = (l)->next)
++ for (; (l) != NULL && (p = (l)->data, 1); (l) = (l)->next)
+
+ void gr_ref_incr (GrRef *ref);
+ void gr_ref_decr (GrRef *ref);
diff --git a/games-sports/gracer/files/gracer-0.1.5-libpng14.patch b/games-sports/gracer/files/gracer-0.1.5-libpng14.patch
new file mode 100644
index 000000000000..6230eb276401
--- /dev/null
+++ b/games-sports/gracer/files/gracer-0.1.5-libpng14.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/show_bug.cgi?id=308885
+
+--- common/gr_texture.c
++++ common/gr_texture.c
+@@ -419,7 +419,7 @@ read_png_file (GrTexture *texture, char
+ if (fread (header, 1, PNG_BYTES_TO_CHECK, file) != PNG_BYTES_TO_CHECK) {
+ goto ERROR;
+ }
+- if (!png_check_sig (header, PNG_BYTES_TO_CHECK)) {
++ if (png_sig_cmp (header, 0, PNG_BYTES_TO_CHECK)) {
+ goto ERROR;
+ }
+
diff --git a/games-sports/gracer/files/gracer-0.1.5-png15.patch b/games-sports/gracer/files/gracer-0.1.5-png15.patch
new file mode 100644
index 000000000000..1efaec3d6fc6
--- /dev/null
+++ b/games-sports/gracer/files/gracer-0.1.5-png15.patch
@@ -0,0 +1,11 @@
+--- common/gr_texture.c.old 2011-09-14 14:23:46.820207882 +0200
++++ common/gr_texture.c 2011-09-14 14:24:22.861203604 +0200
+@@ -431,7 +431,7 @@
+ if (!info_ptr) {
+ goto ERROR;
+ }
+- if (setjmp (png_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf(png_ptr))) {
+ goto ERROR;
+ }
+ png_init_io (png_ptr, file);
diff --git a/games-sports/gracer/files/gracer-gcc-3.4.patch b/games-sports/gracer/files/gracer-gcc-3.4.patch
new file mode 100644
index 000000000000..354f9865a655
--- /dev/null
+++ b/games-sports/gracer/files/gracer-gcc-3.4.patch
@@ -0,0 +1,120 @@
+--- src/glbind.c.old 2004-11-05 01:15:07.141221016 +0000
++++ src/glbind.c 2004-11-05 01:15:32.808319024 +0000
+@@ -2150,6 +2150,7 @@
+ return 3;
+
+ default:
++ ;
+ }
+
+ ERROR:
+@@ -2889,6 +2890,7 @@
+ return 6;
+
+ default:
++ ;
+ }
+
+ ERROR:
+@@ -3081,6 +3083,7 @@
+ return 4;
+
+ default:
++ ;
+ }
+
+ ERROR:
+--- src/glutwidgets.c.old 2004-11-05 01:17:17.941336376 +0000
++++ src/glutwidgets.c 2004-11-05 01:18:42.059548464 +0000
+@@ -255,6 +255,7 @@
+ widget->width += (width - screen_width);
+ break;
+ default:
++ ;
+ }
+ switch (widget->anchor & GR_VERTICAL_MASK) {
+ case GR_BOTTOM:
+@@ -268,6 +269,7 @@
+ widget->height += (width - screen_height);
+ break;
+ default:
++ ;
+ }
+ glut_widget_calc_bbox (widget);
+ }
+@@ -327,6 +329,7 @@
+ break;
+
+ default:
++ ;
+ }
+ }
+
+@@ -504,6 +507,7 @@
+ break;
+
+ default:
++ ;
+ }
+ }
+
+@@ -1299,6 +1303,7 @@
+ break;
+
+ default:
++ ;
+ }
+ }
+
+@@ -1571,6 +1576,7 @@
+ break;
+
+ default:
++ ;
+ }
+
+ glColor4fv (widget->fg_color[GR_STATE_NORMAL]);
+--- src/gr_world.c.old 2004-11-05 01:19:30.766143936 +0000
++++ src/gr_world.c 2004-11-05 01:19:07.717647840 +0000
+@@ -169,6 +169,7 @@
+ break;
+
+ default:
++ ;
+ }
+
+ tlist = entry->triggers;
+--- ac2scene/ac2scene.c.old 2004-11-05 01:13:55.845059680 +0000
++++ ac2scene/ac2scene.c 2004-11-05 01:14:32.526483256 +0000
+@@ -162,6 +162,7 @@
+ break;
+
+ default:
++ ;
+ }
+
+ return 0;
+@@ -234,6 +235,7 @@
+ break;
+
+ default:
++ ;
+ }
+
+ return 0;
+@@ -316,6 +318,7 @@
+ }
+ break;
+ default:
++ ;
+ }
+
+ return 0;
+@@ -399,6 +402,7 @@
+ break;
+
+ default:
++ ;
+ }
+ }
+