summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-05-05 15:59:34 -0400
committerJames Le Cuirot <chewi@gentoo.org>2020-12-09 22:41:13 +0000
commit2ecbc25f3925991ea36559f0b0e25fa634c34a02 (patch)
tree890fe4f9aff0aabab46b488d676bae882406eb68 /games-strategy/julius/julius-1.4.1.ebuild
parentgames-arcade/jazz2: Bump to 0.6.5, drop old 0.6.4 (diff)
downloadgentoo-2ecbc25f3925991ea36559f0b0e25fa634c34a02.tar.gz
gentoo-2ecbc25f3925991ea36559f0b0e25fa634c34a02.tar.bz2
gentoo-2ecbc25f3925991ea36559f0b0e25fa634c34a02.zip
games-strategy/julius: new package
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Horea Christian <chr@chymera.eu> Closes: https://github.com/gentoo/gentoo/pull/15660 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-strategy/julius/julius-1.4.1.ebuild')
-rw-r--r--games-strategy/julius/julius-1.4.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-strategy/julius/julius-1.4.1.ebuild b/games-strategy/julius/julius-1.4.1.ebuild
new file mode 100644
index 000000000000..06b33f139f83
--- /dev/null
+++ b/games-strategy/julius/julius-1.4.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Feature-faithful open source re-implementation of Caesar III"
+HOMEPAGE="https://github.com/bvschaik/julius"
+SRC_URI="https://github.com/bvschaik/julius/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick,video,sound]
+ media-libs/sdl2-mixer
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto /etc/profile.d
+ doins "${FILESDIR}"/90julius.sh
+ cmake_src_install
+ mv "${ED}"/usr/bin/julius "${ED}"/usr/bin/julius-game ||
+ die "Failed to rename executable (required as per conflict with app-accessibility/julius)"
+}
+
+pkg_postinst() {
+ ewarn "Julius requires you to download the original Caesar 3 resources."
+ ewarn
+ ewarn "You need to obtain these files from a vendor of the proprietary software."
+ ewarn "You will then need to copy the 'app' directory into '~/.cache/julius/'."
+ ewarn "One way to obtain this directory is to download the GOG Cesar 3 edition."
+ ewarn "You can then produce this directory by running:"
+ ewarn " innoextract -m setup_caesar3_2.0.0.9.exe"
+ ewarn
+ ewarn "Lastly, run 'source /etc/profile' to refresh your environment and be able"
+ ewarn "to start the game directly by running 'julius-game' in the command line."
+}