summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-02-14 11:57:25 +0000
committerJames Le Cuirot <chewi@gentoo.org>2021-02-14 11:57:25 +0000
commit7404cd9230a8feee90ce53d4779e656bb4477e4a (patch)
treea82b7ce4776b37869fcecb0024ec7272792b0a28 /games-strategy/julius/julius-1.4.1.ebuild
parentdev-util/gdbus-codegen: bump to 2.66.7 (diff)
downloadgentoo-7404cd9230a8feee90ce53d4779e656bb4477e4a.tar.gz
gentoo-7404cd9230a8feee90ce53d4779e656bb4477e4a.tar.bz2
gentoo-7404cd9230a8feee90ce53d4779e656bb4477e4a.zip
games-strategy/julius: Rename binary without breaking desktop file
Closes: https://bugs.gentoo.org/770121 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-strategy/julius/julius-1.4.1.ebuild')
-rw-r--r--games-strategy/julius/julius-1.4.1.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/games-strategy/julius/julius-1.4.1.ebuild b/games-strategy/julius/julius-1.4.1.ebuild
index bffe7ad84787..dc3f63777c18 100644
--- a/games-strategy/julius/julius-1.4.1.ebuild
+++ b/games-strategy/julius/julius-1.4.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake xdg
+inherit xdg cmake
DESCRIPTION="Feature-faithful open source re-implementation of Caesar III"
HOMEPAGE="https://github.com/bvschaik/julius"
@@ -18,19 +18,18 @@ DEPEND="
media-libs/libsdl2[joystick,video,sound]
media-libs/sdl2-mixer
"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ ${DEPEND}
+"
-src_prepare() {
- cmake_src_prepare
- xdg_src_prepare
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.1-rename.patch
+)
src_install() {
insinto /etc/profile.d
doins "${FILESDIR}"/90julius.sh
cmake_src_install
- mv "${ED}"/usr/bin/julius "${ED}"/usr/bin/julius-game ||
- die "Failed to rename executable (required as per conflict with app-accessibility/julius)"
}
pkg_postinst() {