summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-02 19:24:57 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-02 21:27:38 +0200
commit3f300ea4c571f59e8a188729db8121eb760e8869 (patch)
tree5e245b1ce4c86064df61b852d33ef319a2719597 /games-strategy
parentgames-strategy/galaxyhack: Drop old (diff)
downloadgentoo-3f300ea4c571f59e8a188729db8121eb760e8869.tar.gz
gentoo-3f300ea4c571f59e8a188729db8121eb760e8869.tar.bz2
gentoo-3f300ea4c571f59e8a188729db8121eb760e8869.zip
games-strategy/glob2: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/glob2/files/glob2-0.9.4.4-gcc44.patch4
-rw-r--r--games-strategy/glob2/files/glob2-0.9.4.4-scons-blows.patch4
-rw-r--r--games-strategy/glob2/glob2-0.9.4.4-r2.ebuild64
3 files changed, 68 insertions, 4 deletions
diff --git a/games-strategy/glob2/files/glob2-0.9.4.4-gcc44.patch b/games-strategy/glob2/files/glob2-0.9.4.4-gcc44.patch
index 5ce62ea6e46c..8d2da78cee23 100644
--- a/games-strategy/glob2/files/glob2-0.9.4.4-gcc44.patch
+++ b/games-strategy/glob2/files/glob2-0.9.4.4-gcc44.patch
@@ -1,5 +1,5 @@
---- libgag/include/StreamBackend.h.old
-+++ libgag/include/StreamBackend.h
+--- a/libgag/include/StreamBackend.h.old
++++ b/libgag/include/StreamBackend.h
@@ -28,6 +28,9 @@
#ifdef putc
#undef putc
diff --git a/games-strategy/glob2/files/glob2-0.9.4.4-scons-blows.patch b/games-strategy/glob2/files/glob2-0.9.4.4-scons-blows.patch
index b0fb92d47974..b3e6e86eb485 100644
--- a/games-strategy/glob2/files/glob2-0.9.4.4-scons-blows.patch
+++ b/games-strategy/glob2/files/glob2-0.9.4.4-scons-blows.patch
@@ -1,5 +1,5 @@
---- SConstruct.orig
-+++ SConstruct
+--- a/SConstruct.orig
++++ b/SConstruct
@@ -1,6 +1,7 @@
EnsureSConsVersion(0, 96, 92)
import sys
diff --git a/games-strategy/glob2/glob2-0.9.4.4-r2.ebuild b/games-strategy/glob2/glob2-0.9.4.4-r2.ebuild
new file mode 100644
index 000000000000..fe7cdc7b1729
--- /dev/null
+++ b/games-strategy/glob2/glob2-0.9.4.4-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop gnome2-utils scons-utils
+
+DESCRIPTION="Real Time Strategy (RTS) game involving a brave army of globs"
+HOMEPAGE="http://globulation2.org/"
+SRC_URI="mirror://nongnu/glob2/${PV:0:5}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/boost-1.34[threads]
+ dev-libs/fribidi
+ media-libs/libsdl[opengl]
+ media-libs/libvorbis
+ media-libs/sdl-image[png]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ media-libs/speex
+ virtual/glu
+ virtual/opengl
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-{gcc{44,49,6},scons-blows,underlinking}.patch )
+
+src_configure() {
+ myesconsargs=(
+ INSTALLDIR=/usr/share/${PN}
+ DATADIR=/usr/share/${PN}
+ )
+ escons data
+}
+
+src_compile() {
+ escons
+}
+
+src_install() {
+ dobin src/${PN}
+ insinto /usr/share/${PN}
+ doins -r campaigns data maps scripts
+ find "${ED}"/usr/share/${PN} -name SConscript -exec rm -f '{}' +
+ newicon -s 48 data/icons/glob2-icon-48x48.png ${PN}.png
+ make_desktop_entry glob2 "Globulation 2"
+ einstalldocs
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}