summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-20 11:21:06 +0000
committerSam James <sam@gentoo.org>2022-12-20 11:21:06 +0000
commit59198ccb92dfe55f90f39d0104a02c83c8b35dab (patch)
treef2e4cf995db1df7d9333b119feb1f4b47de6736e /games-strategy
parentgames-strategy/wesnoth: add github upstream metadata (diff)
downloadgentoo-59198ccb92dfe55f90f39d0104a02c83c8b35dab.tar.gz
gentoo-59198ccb92dfe55f90f39d0104a02c83c8b35dab.tar.bz2
gentoo-59198ccb92dfe55f90f39d0104a02c83c8b35dab.zip
games-strategy/wesnoth: drop 1.16.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/Manifest1
-rw-r--r--games-strategy/wesnoth/wesnoth-1.16.3.ebuild100
2 files changed, 0 insertions, 101 deletions
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index 087146f1321c..a621190038af 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,3 +1,2 @@
-DIST wesnoth-1.16.3.tar.gz 518049863 BLAKE2B e862de2e6f71a1dfe11b0cb6343ea1da78c0eb035893d7bd16ca86586b689b21f39b5266ba86476829c1c9005f7abc37058c2f0ac8ea1ae2970d609880e0da20 SHA512 7f37a1a16ed51ffa935a457553b1a3890398b928bb5893720b746080b37a121a86e21ae402bdddfe30572adccf71a985bf1e3223a0eb443bf7a696ee213d9bf0
DIST wesnoth-1.16.6.tar.gz 518250360 BLAKE2B 3fc5f5827beacc309a42d1d135eadefbace57866397eed4e3c5618ba6372ae31fc0350b2180c1323872ae59789ca67cd1b4a973c2257c7fac59508af93e0b758 SHA512 fcf9e50ce065f7c8d2b940eec88de27f18c3adbb9c7ae238bf6821eef233a45c2bdc7a58d5cd2abc4f37bcab6e503aa72d46f623c882c711d9f06b2826340bf5
DIST wesnoth-1.17.11.tar.bz2 421068195 BLAKE2B 43106bb72c6b4a39b4995fb9804733e5420b636db08254e75e7698c58740b84a33c387194bf048247bddf1808f73d0d07b3816f18687390760fb5fab7c2d8449 SHA512 8208ae1c02d5e6a9fe50a2cf533d3b0b207151e5b877c98b003117641ae3c46ad31dbbe4bc46481f4f30382ae65b0183d7636452de5f6d42c8bd48d040f3dd5a
diff --git a/games-strategy/wesnoth/wesnoth-1.16.3.ebuild b/games-strategy/wesnoth/wesnoth-1.16.3.ebuild
deleted file mode 100644
index 1ee6998e389d..000000000000
--- a/games-strategy/wesnoth/wesnoth-1.16.3.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake flag-o-matic xdg
-
-DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
-HOMEPAGE="http://www.wesnoth.org
- https://github.com/wesnoth/wesnoth"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-# uneven minor versions are development versions
-if [[ $(( $(ver_cut 2) % 2 )) == 0 ]] ; then
- KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-fi
-IUSE="dbus dedicated doc nls server"
-
-RDEPEND="
- acct-group/wesnoth
- acct-user/wesnoth
- dev-libs/boost:=[bzip2,context,icu,nls]
- >=media-libs/libsdl2-2.0.4:0[joystick,video,X]
- !dedicated? (
- dev-libs/glib:2
- dev-libs/openssl:0=
- >=media-libs/fontconfig-2.4.1
- >=media-libs/sdl2-image-2.0.0[jpeg,png]
- >=media-libs/sdl2-mixer-2.0.0[vorbis]
- media-libs/libvorbis
- >=x11-libs/pango-1.22.0
- >=x11-libs/cairo-1.10.0
- sys-libs/readline:0=
- dbus? ( sys-apps/dbus )
- )"
-DEPEND="${RDEPEND}
- x11-libs/libX11
-"
-BDEPEND="
- sys-devel/gettext
- virtual/pkgconfig
-"
-
-src_prepare() {
- cmake_src_prepare
-
- if ! use doc ; then
- sed -i \
- -e '/manual/d' \
- doc/CMakeLists.txt || die
- fi
-
- # respect LINGUAS (bug #483316)
- if [[ ${LINGUAS+set} ]] ; then
- local lang langs=()
- for lang in $(cat po/LINGUAS) ; do
- has ${lang} ${LINGUAS} && langs+=( ${lang} )
- done
- echo "${langs[@]}" > po/LINGUAS || die
- fi
-}
-
-src_configure() {
- filter-flags -ftracer -fomit-frame-pointer
-
- if use dedicated || use server ; then
- mycmakeargs=(
- -DENABLE_CAMPAIGN_SERVER="ON"
- -DENABLE_SERVER="ON"
- -DSERVER_UID="${PN}"
- -DSERVER_GID="${PN}"
- -DFIFO_DIR="/run/wesnothd"
- )
- else
- mycmakeargs=(
- -DENABLE_CAMPAIGN_SERVER="OFF"
- -DENABLE_SERVER="OFF"
- )
- fi
- mycmakeargs+=(
- -Wno-dev
- -DENABLE_GAME="$(usex !dedicated)"
- -DENABLE_DESKTOP_ENTRY="$(usex !dedicated)"
- -DENABLE_NLS="$(usex nls)"
- -DENABLE_NOTIFICATIONS="$(usex dbus)"
- -DENABLE_STRICT_COMPILATION="OFF"
- )
- cmake_src_configure
-}
-
-src_install() {
- local DOCS=( README.md changelog.md )
- cmake_src_install
- if use dedicated || use server ; then
- rmdir "${ED}"/run{/wesnothd,} || die
- newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
- fi
-}